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Disclaimer: Unless otherwise stated, the content in this work is provided for general information only and 
it is not intended to amount to advice on which the reader should rely. OS therefore disclaims all liability 
and responsibility arising from any reliance placed on such content. Professional or specialist advice should 
be obtained before taking, or refraining from, any action on the basis of the content herein. 
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1. Introduction 
This guide explains what GeoPackage is, lists the key features and benefits of the format, and details the 
applications that support GeoPackage features. Section 2 provides step-by-step instructions on how to 
access GeoPackage data via ArcMap, QGIS, MapInfo Professional, ArcGIS Pro and CadCorp. Section 3 
details how to load GeoPackage data into PostgreSQL. Section 4 outlines how to read GeoPackage data 
into FME. 

In response to customer feedback on preferred data formats, a growing number of OS products have been 
made available in GeoPackage format, including AddressBase Core, Boundary-Line, OS Open Zoomstack 
and OS Open Roads, to name a few. 

1.1 What is GeoPackage? 

GeoPackage (.gpkg) is an open, non-proprietary, platform-independent and standards-based data format for 
geographic information systems (GIS), as defined by the Open Geospatial Consortium (OGC). It is designed 
to be a lightweight format that can contain large amounts of varied and complex data in a single, easy to 
distribute and ready to use file. GeoPackage is natively supported by numerous software applications. 

1.2 Key features and benefits of GeoPackage 

GeoPackage offers users the following key features and benefits: 

• The single file is easy to transfer and offers the end-user a rich experience. 

• Attribute names are not limited in length, making the format user-friendly. 

• The file size limit is very large at 140 TB1

1 A file size limit might be imposed by the file system to which the file is written. 

, so lots of data can be easily accommodated – great for  
GB national coverage. 

• It supports raster, vector and database formats, making it a highly versatile solution. 

• It is an OGC standard. 

• In most cases, it is a Plug and Play format. 

• Data will be supplied in British National Grid (ESPG:27700). 
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2. Accessing GeoPackage data via GIS software 
The following sub-sections provide step-by-step instructions on how to access GeoPackage data via 
ArcMap, QGIS, MapInfo Professional, ArcGIS Pro and CadCorp. 

2.1 Accessing GeoPackage data via ArcMap 

Requirements: 

• ArcMap (version 10.2.2 or later) 
• A GeoPackage dataset 

These instructions were created using ArcMap version 10.7, but versions from 10.2.2 onwards will also 
support GeoPackage features. 

1. Open ArcMap. 

2. Once ArcMap loads, select the Add Data button. The icon is an orange-coloured diamond shape with a 
black plus symbol on top; it can be found in the ribbon at the top of the workspace. 

 

If the Add Data button is not visible, an alternate method to add data is to select File > Add Data > 
Add Data. An Add Data dialog box will appear which will be similar to the following screenshot: 

 

If you have not yet connected to the appropriate folder in which you are storing the GeoPackage data, 
you can connect to it by selecting the Add Folder button: 
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3. Once you have connected to the appropriate folder, locate the GeoPackage to upload into ArcMap. 
The .gpkg file will look similar to the one in the following screenshot: 

 

4. Double-click on the GeoPackage file to reveal the layers within it. Select the layers you want to upload 
into ArcMap. 

Note: More than one layer can be selected at any time by holding down shift and clicking on multiple layers. 

 

5. Add the relevant selected GeoPackage layers into the map by clicking the Add button. 

6. The GeoPackage layers should now be viewable in the layers list in the Table Of Contents on the left-
hand side of the workspace. 
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2.2 Accessing GeoPackage data via QGIS 

Requirements: 

• QGIS (version 2.10.1 or later) 
• A GeoPackage dataset 

These instructions were created using QGIS version 3.14. Other versions of QGIS can be used, from 
version 2.10.1 onwards. 

1. Open a new or existing QGIS project. 

2. On the top ribbon of the workspace, add a layer by selecting Layer > Add Layer > Add Vector Layer. 

 

Alternatively, you can simply select the Add Vector Layer button: 
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3. A dialog box will appear. Here, it is possible to select the GeoPackage that will be loaded using the 
three dots button located next to the Vector Dataset(s) box. Click the three dots button. 

 

4. Navigate to the GeoPackage. Double-click the file or select it, then click Add. 

5. A separate dialog box will appear. Here, the layers of the GeoPackage can be selected and added to a 
map. It is possible to add selected layers, numerous layers or all layers. 

 

6. Once the relevant layers have been selected, click OK. 

7. The GeoPackage layers should now be viewable in the layers list on the left-hand side of the workspace. 
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2.3 Accessing GeoPackage data via MapInfo Professional 

Requirements: 

• MapInfo Professional (version 15.2 or later) 
• A GeoPackage dataset 

These instructions were completed using MapInfo Professional version 2019; however, any version from 
15.2 onwards can be used. 

1. Start MapInfo Professional. 

2. Select Open > Table in the top ribbon. 

 

3. A dialog box will appear where you can search for the appropriate GeoPackage. Once located, select 
the GeoPackage and click Open. 
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4. Another dialog box will appear. Here, it is possible to select which layers to import into MapInfo 
Professional from the GeoPackage. 

 

5. Once the layers have been selected, click OK. 

6. The data should now be available in your workspace. 
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2.4 Accessing GeoPackage data via ArcGIS Pro 

Requirements: 

• ArcGIS Pro (version 1.1 or later) 
• A GeoPackage dataset 

These instructions were created using ArcGIS Pro version 2.5, but versions from 1.1 onwards will support 
GeoPackage. 

1. Start ArcGIS Pro, then open an existing project or create a new one. To create a new project, select 
Map from the Blank Templates section, then enter a Name and a Location for the project in the Create 
a New Project section. Click OK. 

 

2. In the ribbon at the top of the project, select Map > Add Data. 

 

3. A dialog box will appear. Navigate to the GeoPackage to be added into ArcGIS Pro. Select the 
GeoPackage and click Open. This will open the GeoPackage to reveal the individual layers. 
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4. The layers can be selected either individually or together. Once the relevant layers have been selected, 
click OK. The selected layers will then be added into ArcGIS Pro. 

Note: More than one layer can be selected at any time by holding down shift and clicking on multiple layers. 

 

5. The layers added into ArcGIS Pro will appear in the contents pane on the left-hand side of the project. 
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2.5 Accessing GeoPackage data via CadCorp 

Requirements: 

• CadCorp SIS 
• A GeoPackage dataset 

These instructions were created using CadCorp SIS 9 Desktop Express; however, other versions of 
CadCorp can support GeoPackage. 

1. Start CadCorp SIS. 

2. In the upper ribbon, select Add Overlay. 

 

3. A dialog box will appear. Select Files > File. 
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4. From here, another dialog box appears where you can map to where the GeoPackage has been stored 
locally. 

 

5. Once the correct GeoPackage has been located, click Finish. 

6. The data should now appear on the map. 
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3. Loading GeoPackage into a database 
The following sub-section provides instructions on how to load GeoPackage datasets into PostgreSQL. 

3.1 Loading a GeoPackage into PostgreSQL (via GDAL / Command 
Prompt) 

Requirements: 

• A development platform for PostgreSQL (for example, pgAdmin or dBeaver) 
• A PostgreSQL database 
• PostGIS extension 
• GDAL 
• Access to a Command Prompt or similar 
• A GeoPackage dataset 

There are various ways of loading a GeoPackage into PostgreSQL. The following step-by-step instructions 
run through using GDAL / Command Prompt to do this. 

1. Open your chosen development platform, for example, dBeaver (this can be found by going to Windows 
Start Menu > PostGreSQL). 

2. Either connect to an existing database or create a new database. It is recommended that the encoding 
is set to UTF-8. We will return to the PostgreSQL development platform later. 

3. Open the Command Prompt by clicking the Start button in the bottom left-hand side of the screen and 
typing cmd into the search bar. 

 

4. The Command Prompt will appear. 
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5. Change the directory of the Command Prompt app if necessary. The directory needs to point to the 
folder where the GeoPackage is stored. For this example, the GeoPackage to be loaded into 
PostgreSQL is stored in a C:\Temp folder. 

6. In the Command Prompt, type cd followed by the directory of the location of the GeoPackage. Press 
Enter on the keyboard. This will change the directory. 

 

7. Enter the command: 

ogr2ogr -progress -gt 65000 -f PostgreSQL "PG:user=<username> password=<password> 
dbname=<database>" -a_srs EPSG:<coordinate_system> <data_name>.gpkg 

username, password, database and host can all be found within the subsequent database. 

coordinate_system is the EPSG of the data to be loaded, for example, to load into British National 
Grid, the EPSG is 27700. 

data_name is the name of the GeoPackage to be loaded. 

Example: 

ogr2ogr -progress -gt 65000 -f PostgreSQL "PG:user=postgres password=PG123 dbname=osdata  
host=localhost" -a_srs EPSG:27700 Greenspace.gpkg 

8. Open your chosen development platform (for example, dBeaver) by going to Start > dBeaver. 

9. Under Database Navigator, move to the database you loaded data into and expand the schema.  
Using the code above, the GeoPackage should be in your default schema (shown in bold). 

10. The GeoPackage will now appear as new tables / a new table in the schema nominated as default. 
Nominate a schema by adding the following text to the command noted in step 7: 

active schema=<schema> 

schema can be found within the subsequent database. 

11. Once loaded, you may want to add Primary and Foreign Keys to the data. These can only be added on 
columns where the data values are unique. Where there are no unique data values, an index may be 
added, which will aid searching. 
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4. Reading GeoPackage data via FME 
Requirements: 

• An FME license 
• A GeoPackage dataset 

GeoPackages can also be read into and used in FME workbenches. 

1. Start up FME. In the top ribbon, click the Add Reader button, which will look similar to the following 
image: 

 

2. A dialog box will appear. Here, the format (GeoPackage in this instance) can be specified using the 
drop-down list. Select the three dots button next to Dataset to specify which GeoPackage you want to 
read. The Coordinate System should also be set appropriately. 

 

3. Click Parameters… 
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4. Another dialog box will appear. Here, specific layers within the GeoPackage can be selected, rather 
than importing the entire file. Additionally, the Search Envelope can be used to clip the GeoPackage to 
an extent. 

 

5. Click the three dots button next to the Tables drop-down menu. 

6. The next dialog box to appear allows for the selection of specific layers. Here, it is possible to select 
which themes / layers should be added into the workbench. 

 

7. Click OK. 

8. An orange reader will appear which will display the name of the GeoPackage table that has been 
‘read in’. 
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