How to get the best out of OS OnDemand
a single view of your latest data wherever you are

Refresh
The world-class data you need is now available online.

How to get the best out of OS OnDemand

Welcome to your OS OnDemand starter guide, designed to ensure you can get the most from your three month trial. It should help you to understand the potential of OS OnDemand and integrate it into your business operations, ensuring your systems are fully compliant.
Introduction to OS OnDemand

OS OnDemand allows you to run your business more efficiently, combining Ordnance Survey’s most up-to-date and accurate mapping with your own data to create a powerful business tool. It provides a simple way to access our trusted mapping and local information, giving you a single view of the data across your entire organisation. So it doesn’t matter if you’re sat side by side or at opposite ends of the country, you can be sure you’re viewing the same information.

OS OnDemand allows you to quickly pan and zoom, letting you view the mapping in great detail, as well as combining data that’s relevant to your business. With our Web Map Tile Service (WMTS) version of OS OnDemand, you can access the information via current versions of OGC compliant software or using the API. This makes customising maps simple and creates a tool that’s perfectly set up for your business where you need to deliver a great, external, browser based experience.

So whether you’re planning emergency responses, calculating insurance premiums, organising infrastructure repairs or planning local services, OS OnDemand is here to help your business run more efficiently and make your life easier.
There are two versions of OS OnDemand – a Web Map Service version (WMS) and a Web Map Tile Service (WMTS) version. The WMS version includes comprehensive access to the full suite of Ordnance Survey mapping products, while the WMTS version includes fewer standard products but also includes our consistently styled zoom map stack enabling easier interpretation of mapping between zoom thresholds. To help you decide which version is right for your organisation, a full list of the products included with each version can be found in the table below.

<table>
<thead>
<tr>
<th>Product</th>
<th>WMS</th>
<th>WMTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>OS MasterMap® Topography Layer (raster format image)</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>OS MasterMap Integrated Transport Network™ Layer Road Networks theme (raster format image)</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>OS MasterMap Integrated Transport Network™ Layer Road Routing Information theme (raster format image)</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>OS MasterMap Integrated Transport Network™ Layer Urban Paths theme (raster format image)</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>OS MasterMap Imagery Layer (25cm)</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>OS VectorMap® Local</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>1:10 000 Scale Raster – Black and White†</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>1:10 000 Scale Raster – Colour†</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>1:25 000 Scale Colour Raster</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>1:50 000 Scale Colour Raster</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Land-Form Profile® Contours</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Land-Form Profile DTM</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>*GB Overview+</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>*GB Overview</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Zoom Map Stack</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>OS OpenData™ products:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OS VectorMap® District</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>1:50 000 Scale Gazetteer</td>
<td>✓</td>
<td>**</td>
</tr>
<tr>
<td>1:250 000 Scale Colour Raster</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Boundary-Line™</td>
<td>✓</td>
<td>**</td>
</tr>
<tr>
<td>Land-Form PANORAMA® Contours</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Land-Form PANORAMA DTM</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Meridian™ 2</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>MiniScale®</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>OS Locator™</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Strategi®</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>OS StreetView® (1:10 000 scale)</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Code-Point Open</td>
<td></td>
<td>**</td>
</tr>
</tbody>
</table>

* These do not form part of the Ordnance Survey product portfolio but are used to provide context at very small scales. No licensing restrictions apply.

** Look-ups

† Note that 1:10 000 Scale Colour Raster and 1:10 000 Scale Black and White Raster will be withdrawn from 31 March 2014.
Web Map Service (WMS)

This is a simple interface for dynamically generating map images including layer(s) and areas of interest from a database.

Each request from the user is called a map transaction. These take time to register, access the database and then create and serve raster tiles. OS OnDemand WMS does this in less than two seconds.

Web Map Tile Service (WMTS)

This is an interface that generates predefined map images from a cache.

Rather than having to get features from the database like the WMS, mapping application programming interfaces (APIs) use preconfigured and rendered map tiles. This reduces the time for seeing mapping to under 0.5 seconds.
How to use OS OnDemand

The following demonstrations show how quickly users can access the OS OnDemand web map service (WMS): http://www.ordnancesurvey.co.uk/oswebsite/web-services/os-ondemand/how-to-connect-to-os-ondemand.html

With Cadcorp software

• Add an OGC Overlay > Select OCC WMS
• Paste in the URL of OS OnDemand WMS > Next
• Enter Username and Password > Next
• You’ll then be presented with a complete list of the products available
• Choose the folders you require and add them to your selected layers > Next
• The setup will already be configured > Finish

This will open a new map with WMS loaded. You can now zoom and pan to view the different products at different scales. You can also overlay your own data, points, lines and polygons as layers over the mapping.

• Add overlay > File > Choose file > Finish

You can then use the functionality of your GIS to change how the information is displayed to suit your requirements.

With ESRI software

• Open Arc Catalogue > GIS Services > Add WMS Servers
• Paste in URL > Get Layers
• Enter Username and Password > OK
• The layers will appear in the left hand box > OK
• Open Arc Map to view WMS
• Add Data > GIS Services > OS OnDemand WMS > Add
• Select the layers you want to view

The map on the right will have your mapping loaded. You can now zoom and pan to view the different products at different scales. You can also overlay your own data, points, lines and polygons as layers over the mapping.

• Add Data > Choose file > Add

You can then use the functionality of your GIS to change how the information is displayed to suit your requirements.

With Map Info software

• File > Open Web Service > Open WMS
• Servers > Add > Paste in URL
• To check that the URL is valid – Test URL > Enter Username and Password > OK
• OS OnDemand Server > Set default > OK
• List of products appear in left hand box > Chosen Layers > Add

The products need to be added in order of scale with the largest scale at the top. Use the following order:

OS MasterMap Cartographic Test
OS MasterMap Typographic Line
OS MasterMap Topographic Area

Then descending scales from 1:10 000 right through to GB Overview

• Change projection to ESPG 27700
• Choose Table Filename and choose what to call the WMS Tab File and where to save it > OK

This opens the map. You can now zoom and pan to view the different products at different scales. You can also overlay your own data, points, lines and polygons as layers over the mapping.

• Open > Choose file > Open

You can then use the functionality of your GIS to change how the information is displayed to suit your requirements.
With QGIS software

- Add Layers > New
- Give your WMS a name, paste the URL and input the Username and Password > OK
- Connect to Service > Input Username and Password > OK
- Select the layers you wish to view
- In Layer Order Tab, list the layers in order of scale from smallest at top to largest at bottom with MM Area last of all
- Go back to the Layers Tab > Change
- Expand Projected Coordinate Systems > Transverse Mercator > OSGB 1936 > OK
- Select Add to add these layers to the map window > Close

This opens the map window. You can now zoom and pan to view the different products at different scales. You can also overlay your own data, points, lines and polygons as layers over the mapping:

- Add Vector Layer > Browse > Select Files > Open > Open

You can then use the functionality of your GIS to change how the information is displayed to suit your requirements.

With Geomedia software

- Open workspace > go to warehouse > new connection
- Select WMS from connection type list
- Give your WMS a name, type in URL for the service
- Click Advanced > Input Username and Password > ok > ok
- Right click on display order window > select Add
- In Add Legends Entries, tick box against connected WMS > ok

Check Projection

- Go to view > GeoWorkspace Coordinate System > choose as required in Projection Space > ok

This will open a new map with WMS loaded. You can now zoom and pan to view the different products at different scales. You can also overlay your own data, points, lines and polygons as layers over the mapping.

With Autodesk software

- Open task pane > click data button > select Connect to data
- Select Add WMS Connection > Enter name for WMS > Enter URL > Click Connect
- Enter Username and Password > Click Login > layers available appear in panel with WGS84 projection

Change Projection

- Double click layer CS Code enter LL84 > Click three dot button > navigate to GB entry in Category box
- Select British NatGrid > ok > click away from layer CS Code to update all entries
- In Server CS Code click on each layer and select EPSG:27700 >tick Combine into one layer
- Tick box for layer required in order of scale from smallest at top to largest at bottom
- Give layer a name > click Add to Map > layer now appears in window

This opens the map window. You can now zoom and pan to view the different products at different scales. You can also overlay your own data, points, lines and polygons as layers over the mapping.

The WMS can also be enabled for browser use.
Accessing OS OnDemand WMTS

The WMTS service option of OS OnDemand can be accessed in three ways:

- OGC WMTS tile request via compliant GIS or web based clients; we will need to register the URL that your client software sends back e.g. ArcGIS = www.ESRI.com. We will be adding basic authentication and IP ranges at a later stage.
- Via the API through an internet browser. You will also require:
  - Notepad or another text file program (to edit and save code).
  - Created Javascript code to embed maps.
- XYZ style tile request via compliant GIS or web based client; you will need to convert from a grid reference to a specific tile request. Details can be found at:
  
  http://www.ordnancesurvey.co.uk/oswebsite/support/web-services/configuring-os-ondemand-wmts.html

An API key (a unique alphanumeric code) will be provided to you when you apply for a licence. You will need to include this code and the URL provided to you in the request you make to the service.

For example coding, visit our OS OnDemand Code Playground. This an interactive way to explore our OS API examples and experiment with your own code. You can edit these and then download your own custom code.

http://www.ordnancesurvey.co.uk/oswebsite/support/web-services/os-ondemand-code-playground.html

We will be adding demonstrations to our web page showing how users can access the OS OnDemand WMTS shortly.
Our Key Service Information

- 99.9% service uptime.
- Service availability: 24/7, 365 days a year.
- All planned maintenance resulting in down time done during non-core hours (8 pm – 8 am weekdays and 8 am – 2 pm Sundays) after giving you notice of 5 working days.
- Ordnance Survey Customer Service Centre 8.30 am – 5.30 pm Monday to Friday.

Best Practice advice

We’ve got lots of experience and expertise in helping OS OnDemand work for a wide range of businesses. Here’s a shortlist of what we view as best practice for helping you to set up the service, getting the most out of OS OnDemand and resolving any issues:

- To help optimise OS OnDemand within your IT department, our technical consultants will be able to offer you advice right from the start.
- If you are using a third party for technical support or delivery, make sure you engage with them as well as our consultants from the outset.
- Identify from the outset what additional functions and data you may want to access and link with the service.
- Make sure you understand the difference between WMS and WMTS. A full list of the products available for each version can be found at: http://www.ordnancesurvey.co.uk/oswebsite/web-services/os-ondemand/products.html
- Make sure you keep an issue log throughout the trial to make resolution of problems easier.
- Involve your IT Security Department during the trial to resolve any firewall issues.
- Have the OS OnDemand user guide to hand throughout the setup process.
- Provide a demo to those departments that will be using OS OnDemand during the trial period.

In case you do encounter any issues, we have gathered a set of FAQs from users that you can find at:
http://www.ordnancesurvey.co.uk/oswebsite/support/os-ondemand.html

If you need further support, please contact us firstly via email at osondemand@ordnancesurvey.co.uk
How to integrate **OS OnDemand** into your business

OS OnDemand is a powerful, yet versatile business tool that provides a raster image suite of Ordnance Survey products. It can be successfully integrated into diverse sectors and used for a wide variety of purposes to add value to your operations:

- Central Government – policy making and resource planning.
- Local Government – event planning and funding applications.
- Utilities – detailed contextual mapping to support asset management including street works.
- Commercial – facilities and portfolio management.

To help you optimise OS OnDemand within your existing IT operations, our consultants will be able to work with you, providing advice and guidance right from the start of the process. This means it can be incorporated into your own business systems, Intranet or Internet pages, offering you consistent cross-functional information.*

Both our WMS and WMTS versions meet the Open Geospatial Consortium web services standard for use via GIS or web browser. Our WMTS is based on the latest OpenLayers version providing touch screen functionality, ideal for use with mobile applications. All this means that OS OnDemand is not just another tool to bolt onto your operations, but part of a fully integrated system that adds real value to your organisation, saving you both time and money.

*Subject to licence conditions
What has **OS OnDemand** done for businesses?

**Openreach** (WMS)

Openreach has to carry out thousands of street works every year throughout the country. For each street work site, a detailed and up-to-date map is required, overlaid with Openreach information. When relying on the street works notification system, Openreach was subject to significant fines when notification errors were made.

‘The bill for Openreach last year for fixed penalty notices was a seven-figure sum. Since the adoption of OS OnDemand we have seen a five-figure compound fall per month.’

**Hampshire Fire and Rescue** (WMS)

Successfully piloted the service in January 2010 and then moved onto a full license, with OS OnDemand rolled out within its Risk Intelligence section.

‘We can reduce our reliance on the costly data storage infrastructure we have been using. We also know the data served to us is as current as possible, without having to worry about managing updates.’

**The Coal Authority** (WMS)

The Coal Authority was looking to deliver a new online customer interface based on a reliable and cost effective infrastructure that was resilient enough to deal with a large number of users.

‘Using OS OnDemand has delivered significant cost savings, while also improving transparency and efficiency. On top of the £100 000 saving in terms of infrastructure costs, we estimate a continued saving of £20 000 year-on-year, as the fees are less expensive than supporting and maintaining the infrastructure ourselves.’

**Warwickshire County Council** (WMS)

Authority created public consultation website as part of their involvement in a national project to extend the broadband network into areas not economic for the Telcos to reach.

‘I have used all the free software, (QGIS and DeepZoom), with your excellent OS OnDemand service to produce shaded bitmaps; which can be zoomed down to house level very quickly. Your service ensures we are always using the best maps available and we dont have to worry about keeping them up to date - you do that.’

**South Yorkshire Fire and Rescue** (WMS and WMTS)

OS OnDemand enables South Yorkshire Fire and Rescue to use a single web-based view of its geographic location data across a range of systems and platforms, from fire incident data to the location of fire hydrants.

‘Advanced mapping techniques are providing an important way for us to plan how we deliver our services and also to analyse and report on our work. With OS OnDemand, for the first time the whole organisation are able to access this information and make sure our work is as effective and targeted as possible.’
How can I convince stakeholders that OS OnDemand is right for our business?

We understand there are often several stakeholders that need to sign off any move to a new mapping system. There are many advantages of using OS OnDemand within your business that can be communicated to those in your organisation, both to explain the value of OS OnDemand and to overcome any objections:

- Superior level of data accuracy, richness and currency.
- Allows you to deliver top quality services with reduced resources, providing great value.
- Ongoing cost savings due to minimal infrastructure costs.
- Can deliver cost reductions in asset management, including creation of internal web services.
- Can be integrated into all areas of your business, including home-working and mobile access.
- Satisfies end-user demand for instant, responsive and dynamic services.
- Can add value to your own data by integrating it with our mapping.
- Outstanding expert technical support.
We hope that this starter guide has provided everything you need to get OS OnDemand up and running in your organisation. We believe that during your three month trial you will be able to realise fully the value of such a powerful tool to your business.

We hope that at the end of your trial, you will want to continue using OS OnDemand, if so, then we’ve made it simple for you to move onto a full license. All you need to do is contact your account manager and complete a product order form for your full license, indicating whether you require WMS or WMTS, and we’ll do the rest, including helping you choose the appropriate usage band.

For the WMS option, you will be provided with a new Username and Password for your full licence. But to make life easy, you will be able to continue using both your full and trial login details for a short time after you move onto a full licence.

For the WMTS option, you will be able to continue using your existing API key. If you have any additional URLs to register, please let us know.

We hope, both during your trial and beyond, that you find OS OnDemand a valuable addition to your business, helping it to save your organisation time and money, while making your life easier.