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Version history 
Version Date Description 

1.1 2019 First release of the document. 
2.0 01/2023 Full restructure and update of the content 

 

Purpose of this document 
This document provides information about and insight into the OS Open Names product and its potential 
applications. For information on the contents and structure of OS Open Names, please refer to the 
Overview and Technical Specification. 

The terms and conditions on which OS Open Names is made available to you and your organisation are 
contained within Open Government Licence (https://www.nationalarchives.gov.uk/doc/open-government-
licence/version/3/), which allows you to use OS Open Names in any way and for any purpose. We simply 
ask that you acknowledge us with: "Contains OS data © Crown Copyright (and Crown database rights) 
2023". 

We may change the information in this document at any time, giving you the notice period set out in your 
contract. We do not accept responsibility for the content of any third-party websites referenced or 
accessed in or through this document. 

This document has been screened according to Ordnance Survey's Equality Scheme. If you have difficulty 
reading this information in its current format and would like to find out how to access it in a different 
format (braille, large print, computer disk or in another language), please contact us on: 
+44 (0)3456 05 05 05. 

Copyright in this document 
© Ordnance Survey Limited 2023. This document (including for the avoidance of doubt, any mapping 
images reproduced within it) is protected by copyright and apart from the rights expressly granted within 
this document to use the content, all rights are reserved. Any part of this document may be copied for use 
internally in your organisation or business so that you can use OS Open Names under the terms of your 
licence (but not otherwise). 

No part of this document may be reproduced or transmitted in any form or by any means (including 
electronically) for commercial exploitation, onward sale or as free promotional material without getting the 
written consent of Ordnance Survey beforehand. 

Trade marks 
Ordnance Survey, OS, the OS Logos, and OS MasterMap are registered trade marks, and OS Open Names 
is a trade mark of Ordnance Survey, Britain’s mapping agency. 

Microsoft Excel is a registered trademark of Microsoft Corporation. 

Contact details 
OS website ‘Contact us’ page (https://www.ordnancesurvey.co.uk/contact-us).  

http://www.nationalarchives.gov.uk/doc/open-government-licence/version/3/
https://www.nationalarchives.gov.uk/doc/open-government-licence/version/3/
https://www.nationalarchives.gov.uk/doc/open-government-licence/version/3/
https://www.ordnancesurvey.co.uk/contact-us
https://www.ordnancesurvey.co.uk/contact-us
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1. Introduction to the product 
OS Open Names is a geographic directory that contains basic information about identifiable places in Great 
Britain. The content is divided into themes based on type and local type classification values. The data 
contains accurate and current settlement names, road names and numbers, postcodes and their locations, 
additional contextual information and links to other datasets. The primary use of the product is to provide 
the location of named places to support a wealth of activities, such as discovery, identification, visualisation, 
geocoding, routing and navigation, and linking of diverse information.   

 

Figure 1: OS Open Names example map showing geographical locations for identifiable places. 

This getting started guide focusses on using the product in comma-separated values (CSV) format. 

For guidance on using the product in GeoPackage format, please see the separate Getting started with 
GeoPackage guide, which is available on the OS Open Names support page of the OS website 
(https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support). 

https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
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2. Obtaining OS Open Names data 

2.1 Product supply 

The OS Open Names product is supplied in three formats (CSV, GML and GeoPackage) as an online 
download and as an application programming interface (API), both of which can be accessed from the OS 
Data Hub (https://osdatahub.os.uk/). 

2.2 Update schedule 

Updates are supplied quarterly (January, April, July and October) and are provided as a complete resupply. 
Any features that are deleted between supplies are not included in the resupply. 

2.3 Coverage 

OS Open Names covers named places for Great Britain. 

2.4 File size 

The approximate file size of each data format is as follows: 

• CSV: 1.65Gb 

• GML: 9.1Gb 

• GeoPackage: 2.1Gb 

2.5 File structure 

2.5.1 CSV 

The file structure of OS Open Names CSV format supply is: 

• Root folder:  Readme.txt (summary of supplied data). 

• Doc folder: OS_Open_Names_Headers.csv (description of column headers) and licence.txt (important 
licencing information). 

• Data folder: 819 files in CSV format. 
Each file contains data for a 20x20km area labelled with the corresponding grid reference, for example 
HP40.csv. 

https://osdatahub.os.uk/
https://osdatahub.os.uk/
https://osdatahub.os.uk/
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The structure of OS Open Names supplied in CSV is described in the Technical Specification available on 
the OS Open Names support page of the OS website (https://www.ordnancesurvey.co.uk/business-
government/tools-support/open-map-names-support).  

 

2.5.2 GeoPackage 

The file structure of OS Open Names GeoPackage format supply is: 

• Root folder:  Readme.txt (summary of supplied data). 

• Doc folder: licence.txt (important licencing information). 

• Data folder: opname_gb.gpkg (single file in GeoPackage format). 
This file is a self-contained database. 

The structure of OS Open Names supplied in GeoPackage is described in the Technical Specification 
available on the OS Open Names support page of the OS website 
(https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support).  

 

2.5.3 GML 

The file structure of OS Open Names GML format supply is: 

• Root folder:  Readme.txt (summary of supplied data). 

• Doc folder: OS_Open_Names_Headers.csv (description of column headers) and licence.txt (important 
licencing information). 

• Data folder: 819 files in GML format. 
Each file contains data for a 20x20km area labelled with the corresponding grid reference, for example 
HP40.gml. 

The structure of OS Open Names supplied in GML format is described in the product's Technical 
Specification, which is available on the OS Open Names support page of the OS website 
(https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support).  

2.6 Metadata 

OS Open Names metadata is ISO 19115 UK GEMINI 2 compliant. For more information, see 
OSOpenNames.xml (https://www.ordnancesurvey.co.uk/xml/products/OSOpenNames.xml) on the Product 
and service metadata page of the OS website  (http://www.ordnancesurvey.co.uk/oswebsite/xml/products/). 

https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/open-map-names-support
https://www.ordnancesurvey.co.uk/xml/products/OSOpenNames.xml
https://www.ordnancesurvey.co.uk/xml/products/OSOpenNames.xml
http://www.ordnancesurvey.co.uk/oswebsite/xml/products/
http://www.ordnancesurvey.co.uk/oswebsite/xml/products/
http://www.ordnancesurvey.co.uk/oswebsite/xml/products/
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3. CSV file processing 
As OS Open Names data is supplied in separate CSV files labelled by two-digit grid references, the files 
require processing before you can load them into a GIS.  

3.1 Moving the header CSV file 

The first step is to combine the individual CSV files with the header CSV file. 

To move and rename the header CSV file: 

1. Extract opname_csv_gb.zip to a folder on your computer.  

2. Open the Doc folder and either move or copy OS_Open_Names_Header.csv into the Data folder. 

3. Rename OS_Open_Names_Header.csv to a_OS_Open_Names_Header.csv.  
 
Adding the “a_” prefix ensures that the files will be merged in the correct order. The header file will be added 
first in the output file as it is now at the top of the file list.   

 
Figure 2: Screenshot in Windows Explorer showing renamed header CSV displayed at the top of the file list. 

3.2 Combining multiple CSV files 

This section contains an example of one way to combine the individual CSV files into a single file using a 
batch (.bat) file. 

Note: The combined CSV file will be approximately 1.7Gb with about 2.9 million records. If opened in Microsoft 
Excel, only the first million records can be seen as the software cannot display more than this. 
 

To combine the CSV files using a batch function: 

1. Copy the following text and paste it into a new Notepad file: copy *.csv outputfile.csv. 

2. Save the Notepad file with the .bat file extension (for example, combine_csv.bat) in the Data folder that 
contains the 819 CSV files. 

3. Close the .bat file, navigate to the Data folder and double click on the batch (.bat) file that you saved in 
the previous step. 
 
A MS-DOS window will open automatically and then close when the process is complete. 
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4. A new CSV file named outputfile.csv will display in the Data folder. You can now delete the other CSV 
files if you like. 
 
outputfile.csv contains the content previously in the 819 individual CSV files that was copied over during the 
batch file process. 

 

Figure 3: Screenshot in Windows Explorer showing outputfile.csv and combine_csv.bat. 

You will now have an output file that is ready to be used in a GIS application or database.  
 
Note: outputfile.csv might be too large to be opened in a text editor. 
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4. Loading the data in a GIS 
This section describes how to load the combined CSV output file into five commonly-used GIS applications: 

• QGIS 

• ArcGIS Pro 

• ArcMap 

• MapInfo Pro 

• Cadcorp SIS Desktop 

4.1 QGIS 

The following step-by-step instructions show you how to load OS Open Names CSV files into QGIS. They 
were prepared using QGIS Desktop version 3.  
 
QGIS is an open-source GIS in which you can create, edit, visualise and publish geographic information. You 
can download it for free from the Download QGIS for your platform page of the QGIS website 
(http://www.qgis.org/en/site/forusers/download.html). 

4.1.1 Loading and displaying the CSV supply 

To load and display CSV data in QGIS: 

1. Open an existing project in QGIS or create a new one. 

2. From the Layer tab, click Add Layer > Add Delimited Text Layer… or click  in the Manage Layers 
toolbar. 

 
Figure 4: QGIS UI showing the Layer > Add Layer > Add Delimited Text Layer menu option. 

http://www.qgis.org/en/site/forusers/download.html
http://www.qgis.org/en/site/forusers/download.html
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3. In the Data Source Manager | Delimited Text dialog: 

a. File name: Click the ellipsis button (…), then navigate to and select the saved outputfile.csv. 

b. File Format: Select CSV (comma separated values). 

c. Record and Fields Options: Select First Record has field names. 

d. Geometry Definition: 

i) Point coordinates: Select this option. 

ii) X field: Choose Eastings (or EA if the abbreviated column header was selected). 

iii) Y field: Choose Northings (or NO if the abbreviated column header was selected). 

iv) Geometry CRS: Select EPSG:27700 – OSGB 1936 / British National Grid. 

e. Click Add. 

 

Figure 5: QGIS Data Source Manager | Delimiter Text dialog. 

It may take a while for the data to load into the map pane. The result will look similar to the example below. OS 
Maps API Light 27700 was used as the background map for this example. 
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Figure 6: QGIS UI showing loaded OS Open Names data in the map pane. 

4. Save outputfile in the format of your choosing. 
 
This will avoid having to repeat the process of geoprocessing outputfile.csv every time you need to use it. 
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4.2 ArcGIS Pro 

The following step-by-step instructions show you how to load OS Open Names CSV files into ArcGIS Pro. 
They were prepared using version 3.0. 

4.2.1 Loading and displaying the CSV supply 

To load and display CSV data in ArcGIS Pro: 

1. Open ArcGIS Pro and create a new project. 

2. In the Create a New Project dialog: 

a. Name: Enter a project name. 
Open_Names in this example. 

b. Location: Browse to and select the location to which you want to save the project. 

c. Create a new folder for this project: Leave this option selected (default setting). 

d. Click OK. 

 
Figure 7: ArcGIS Pro Create a New Project dialog, 

3. When the project opens, add a background map for geographic context. 
 
OS Maps API Light 27700 was added as the background map in this example. 

4. From the Map tab, click Add Data > XY Point Data. 
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Figure 8: ArcGIS Pro UI showing the Map > Add Data > XY Point Data menu option. 

A Geoprocessing pane will open to the right side of the map pane. 

5. In the Geoprocessing pane: 

a. Input Table: Click  to navigate to and select outputfile.csv. 

b. Output Feature Class: This will auto-populate. 

c. X Field: Select GEOMETRY_X 

d. Y Field: Select GEOMETRY_Y 

e. Coordinate System: Select Current Map [Map].  
 
This will populate as British National Grid as OS Maps API Light 27700 map was added as a background 
map (step 3. above). 

 

Figure 9: ArcMap Pro Geoprocessing pane showing Parameters field options. 
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f. Click Run at the bottom right of the Geoprocessing pane. 

 

Figure 10: ArcMap Pro Geoprocessing pane showing Run button and initialization progress. 

It may take a while for the data to load into the map pane. The result will look similar to the example 
below. 

 

Figure 11: ArcGIS Pro UI showing loaded OS Open Names data in the map pane. 

This process results in the creation of a new file geodatabase in the new folder that was selected when the 
project was created (step 2. above). 
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4.3 ArcMap 

The following step-by-step instructions show you how to load OS Open Names CSV files into ArcMap. 
They were prepared using version 10.7.1. 

4.3.1 Loading and displaying the CSV supply 

To load and display CSV data in ArcMap: 

1. Open ArcMap. 

2. Click  (Add Data button) in the toolbar. 

 

Figure 12: ArcMap toolbar. 

3. In the Add Data dialog, navigate to and select outputfile.csv, and then click Add. 

 

Figure 13: ArcMap Add Data dialog. 

4. The file will now display in the Table Of Contents. 

 

Figure 14: ArcMap Table Of Contents. 
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5. Right-click outputfile.csv in the Table of Contents and select Display XY data…in the context menu. 

 

Figure 15: ArcMap Table Of Contents showing the Display XY Data… action selected in the context menu. 
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6. In the Display XY Data dialog: 

a. X Field: Select GEOMETRY_X 

b. Y Field: Select GEOMETRY_Y 

c. Coordinate System of the Input Coordinates: Select British National Grid. 

d. Click OK. 

 

Figure 16: ArcMap Display XY Data dialog. 
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e. Click OK to close the warning dialog. 
 
The Table Does Not Have Object-ID Field warning dialog alerts you to the fact that the resulting layer file is 
only a temporary table and needs to be saved (see step 7. below). 

 

Figure 17: ArcMap Table Does Not Have Object-ID Field warning dialog. 

It may take a while for the data to load into the map pane. The result will look similar to the example 
below. OS Maps API Light 27700 was used as the background map for geographic context. 

 

Figure 18: ArcMap UI showing loaded OS Open Names data in the map pane. 

To use the points in a meaningful way, you need to save the layer as a shapefile.  

7. To save the layer as a shapefile: 

a. Right-click outputfile.csv Events in the Layers panel and then click Export in the context menu. 

b. In the Export Data dialog, browse to and select a filename for the data, and then click OK. 
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Figure 19: ArcMap Export Data dialog showing selected shapefile. 

The shapefile may take a while to create. You can monitor the progress in the Export Progress window that 
opens automatically. This window will close when the export is complete. 

8. You will be given the option to add the newly created data to the workspace. Click Yes, to create a 
shapefile (and associated files) at the chosen location. 

 

Figure 20: ArcMap alert dialog providing the option to add exported shapefile to the map as a layer. 

4.4 MapInfo Pro 

The following step-by-step instructions show you how to load OS Open Names CSV files into MapInfo.  
They were prepared using version MapInfo Pro 2019 (release build 58). 

4.4.1 Loading and displaying the CSV supply 

To load and display CSV data in MapInfo Pro: 

1. Open MapInfo Pro. 

2. Select Open > Blank Workspace. 
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Figure 21: MapInfo Pro Open > Blank Workspace action. 

3. Add a background map for geographic context. 
 
OS Maps API Light 27700 was added as the background map in this example. 

4. From the HOME tab, click Open Table. 

 

Figure 22: MapInfo Pro Home > Open Table action. 

5. In the Open dialog: 

a. Files of type: Change MapInfo.tab to Comma delimited CSV (*.csv). 

b. Browse to and select outputfile.csv. 

c. Click Open. 
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Figure 23: MapInfo Pro Open dialog showing outputfile.csv selected. 

6. In the Comma Delimited CSV Information dialog: 

a. Delimiter: Ensure that Other is checked and that a comma is visible in the box next to it. 

b. Check the Use First Line for Column Titles option. 

c. Click OK. 

 

Figure 24: MapInfo Pro Comma Delimited CSV Information dialog. 

When the table has loaded, the outputfile Browser window will open. This may take a while. 
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Figure 25: MapInfo Pro outputfile Browser window 

7. To create the points from the table, from the SPATIAL tab click Create > Create Points. 

 

Figure 26: MapInfo Pro UI showing the Spatial > Create > Create Points action and the outputfile Browser window. 

8. In the Create Points dialog: 

a. Projection: Change this from Longitude / Latitude (WGS 84) to British National Grid [EPSG:27700]. 
 
The easiest way to do this is to click the ellipsis button (to the right of the Projection field), press B on your 
keyboard 6 times, highlight British National Grid [EPSG:27700] in the results, and then click OK. 

b. using Symbol: Optionally, change the symbol from a square (default style) by clicking the symbol 
button and following the instructions.  
 
This example uses a red star that is more visible than the default square. 

c. Leave the other settings as they are (including Get X Coordinates from: GEOMETRY_X and Get Y 
Coordinates from: GEOMETRY_Y).  

d. Click OK. 
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Figure 27: MapInfo Pro Create Points dialog. 

A progress bar will display and then close automatically when the geoprocessing is complete. 

 

Figure 28: MapInfo Pro geoprocessing Status dialog. 
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When the process is complete, the points will display in the map pane in your chosen point style. The result will 
look similar to the example below: 

 

Figure 29: MapInfo Pro UI showing loaded OS Open Names data in the map pane. 

A .tab file (and associated .MAP and .ID files) is automatically created in the same folder as outputfile.csv. 
However, these are temporary files created as part of the point creation process and are difficult to query. 

9. To save the outputfile layer as a true .tab file: 

a. From the HOME tab, click Save > Save Copy As.  

b. In the Save Copy As dialog, select outputfile and click Save As… 

 

Figure 30: MapInfo Pro Save Copy As dialog with outputfile selected. 

c. In the Save Copy of Table As dialog, navigate to the location where you would like to save the .tab 
file, name the file, select MapInfo Extended (*.tab) in the Save as type field, and then click Save. 
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Figure 31: MapInfo Pro Save Copy of Table As dialog showing how to save outputfile as a true .tab file. 

A progress bar will once again appear and then disappear when the save has completed. 

The new .tab file, which is far easier to query, will now be available to use in MapInfo. 

4.5 Cadcorp SIS Desktop 

The following step-by-step instructions show you how to load OS Open Names CSV files into Cadcorp SIS.  
They were prepared using version 9.0.2275.64 9 (build date July 17, 2020). 

4.5.1 Loading and displaying the CSV supply 

To load and display CSV data in Cadcorp SIS: 

1. Open Cadcorp 

2. From the File tab, click New > Blank Map. 
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Figure 32: Cadcorp UI showing the File > New > Blank Map action. 

3. Add a background map for geographic context: 
 
Cadcorp has incorporated the OS Data Hub Web Map Tile Service into their Overlays. 

a. Click Add Overlay > Ordnance Survey (GB) > OS (GB) Data Hub > OS Maps API. 

b. In the OS (GB) Data Hub confirmation dialog, select: 

i) Yes, to use the default Cadcorp AKI key. 

ii) No, to enter your own API key. 

c. Click Next>. 
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Figure 33: Cadcorp OS (GB) Data Hub dialog with the OS Maps API option selected. 

d. Select your layer style and then click Finish. 
 
There are four styles in two projections to choose from.  

 

Figure 34: Cadcorp OS Data Hub Maps API Layers dialog. 

 You should now see the OS Maps API in your SIS Workspace Definitions. 

 

Figure 35: Cadcorp UI showing OS Maps API in SIS Workspace Definitions. 

4. From the Create tab, click Insert > Insert Points from CSV File. 
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Figure 36: Cadcorp UI showing Create > Insert > Insert Points from a CSV File action. 

5. Browse to and select outputfile.csv, and then click Next>. 

6. In the Database file dialog: 

a. File Type: Select Delimited. 

b. Click Next>. 

 

Figure 37: Cadcorp Database file dialog showing Delimited option selected. 

7. In the File format dialog: 

a. Field Delimiter: Select Comma. 
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b. Select First Row Contains Field Names. 

c. Click Next>. 

 

Figure 38: Cadcorp File format dialog showing Comma and First Row Contains Field Names options selected. 

8. In the Database columns dialog, click Next>. 
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9. In the Recordset dialog, select which columns can be queried: 

a. To select all columns, click outputfile in the Database Tables/Columns field and then click  
(forward icon). 
 
This adds all columns to the Selected columns field on the right. 

b. Click Next>. 

 

Figure 39: Cadcorp Recordset dialog showing all output file columns in the Selected columns field. 

10. In the View Points dialog: 

a. X Field: Select Geometry_X. 

b. Y Field: Select Geometry_Y. 

The above settings determine which fields have your Easting and Northing. 

c. Click Finish. 
 
You can view the points created counter on the bottom left of the dialog. 
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Figure 40: Cadcorp View Points dialog showing Point Configuration field options. 

It may take a while for the table to load in the map pane. The result will look similar to the example below. 

 

Figure 41: Cadcorp UI showing loaded OS Open Names data in the map pane. 

11. To make the points more visible: 

a. Right-click Imported outputfile in SIS Workspace Definitions and then click Properties in the context 
menu. 

b. In Geometry, select the Override checkbox next to the Pen, Brush and Symbol fields. 

c. In Scale Overrides, change the entry in the Point field to -0.1.  



OS OPEN NAMES – GETTING STARTED GUIDE 
January 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023 Page 32 of 32 
 

 

Figure 42: Cadcorp Overlays dialog showing Styles tab options. 

The points will now be visible and will look similar to the example below. 

 

Figure 43: Cadcorp UI showing loaded OS Open Names data with visible points in the map pane. 
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