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Version history 
Version Date Description 

1.0 02/2018 Initial release 
1.1 03/2021 Addition of Scottish Street information 
1.2 02/2022 Introduction of GeoPackage and vector tiles formats to the product. 
1.3 07/2023 Removal of Section 5.2 'FME' from the document. Sections 1 and 2 combined. 

Improvements made to contents of Annex B. Section on Cadcorp completely 
replaced with new procedures. 

 

Purpose of this document 

This document provides information about and insight into the OS MasterMap Highways Network product 
family and its potential applications. For information on the contents and structure of OS MasterMap 
Highways Network family, please refer to the Product Guide and the Technical Specifications. 

The terms and conditions on which OS MasterMap Highways Network family is made available to you and 
your organisation are contained in that Ordnance Survey customer contract. Please ensure your 
organisation has signed a valid current customer contract to be able to use OS MasterMap Highways 
Network family. 

We may change the information in this document at any time, giving you the notice period set out in your 
contract. We do not accept responsibility for the content of any third-party websites referenced or 
accessed in or through this document. 

This document has been screened according to Ordnance Survey's Equality Scheme. If you have difficulty 
reading this information in its current format and would like to find out how to access it in a different 
format (braille, large print, computer disk or in another language), please contact us on 
+44 (0)3456 05 05 05. 

Copyright in this document 

© Ordnance Survey Limited 2023. This document (including for the avoidance of doubt, any mapping 
images reproduced within it) is protected by copyright and apart from the rights expressly granted within 
this document to use the content, all rights are reserved. Any part of this document may be copied for use 
internally in your organisation or business so that you can use OS MasterMap Highways Network family 
under the terms of your licence (but not otherwise). 

No part of this document may be reproduced or transmitted in any form or by any means (including 
electronically) for commercial exploitation, onward sale or as free promotional material without getting the 
written consent of Ordnance Survey beforehand. 

Trade marks 

Ordnance Survey, OS, the OS Logos, OS MasterMap, AddressBase, GeoPlace, and TOID are registered 
trade marks. ITN, OSGB36, and OS MasterMap Highways Network are trade marks of Ordnance Survey, 
Britain’s mapping agency. 

BaseMap is a registered trade mark of Basemap Ltd. 
OGC is a registered trade mark of Open Geospatial Consortium, Inc. 

Contact details 

OS website ‘Contact us’ page (https://www.ordnancesurvey.co.uk/contact-us).  

https://www.ordnancesurvey.co.uk/contact-us
https://www.ordnancesurvey.co.uk/contact-us
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1. Introduction to the product family 
Ordnance Survey, GeoPlace and Improvement Service have collaborated to bring together Ordnance 
Survey’s detailed road and path information, the National Street Gazetteer (NSG), the Trunk Road Street 
Gazetteer (TRSG), and the Scottish Street Gazetteer (SSG) to create an authoritative road and path 
network for Great Britain: OS MasterMap Highways Network. 

OS MasterMap Highways Network integrates the Unique Street Reference Number (USRN) from the 
gazetteers with the most detailed definitive geometry from Ordnance Survey (Figure 1). It is produced in 
partnership with GeoPlace and the Local Government Association, and as of March 2021, contains data 
created and maintained by Scottish Local Government. 

 

Figure 1. Bringing together data to create OS MasterMap Highways Network. 

The OS MasterMap Highways Network product family includes three core products: 

• OS MasterMap Highways Network – Roads 

• OS MasterMap Highways Network – Routing and Asset Management Information (RAMI) 

• OS MasterMap Highways Network – Paths 

  



 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

OS MasterMap Highways Network products contain a wide range of features, including: 

• Unique Street Reference Number (USRN) 

• Road names from the naming and numbering authority 

• Department for Transport (DfT) road classifications 

• Road maintenance authority 

• Motorway junction to junction information 

• Routing information 

• Information on height, weight, width and length restrictions 

• Special designations 

• Road reinstatement information 

• Connected network across Great Britain (GB), including islands through the Ferry Network 

1.1 Product benefits 

• OS MasterMap Highways Network is a single authoritative view of the road and path network that 
underpins decision making across government as it: 

• Reduces duplication of effort on maintaining highways information across multiple departments and 
datasets 

• Facilitates data-sharing 

• The product provides OS detailed geometry and routing information on highways together with the 
best asset management information from authoritative sources into one central location. 

• It enables planning, routing and navigation for a variety of vehicle types. 

• The USRN as the key identifier for a Street enables systems to share information about the same 
entities without the need to match multiple datasets. With the USRN, you can also easily link to OS's 
AddressBase products, which lets you search for or navigate to an address and find the property access 
and delivery points. 

• The product provides accurate and precise asset management information on who maintains the road 
network, special designations and the type of surface reinstatement value. 
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1.2 Product applications 

OS MasterMap Highways Network is designed to be used as a single source of highway asset management 
by private and public sectors alike. The following table describes some of the key product applications: 

Table 1. Key applications for OS MasterMap Highways Network products. 

Product name Suggested application 

OS MasterMap Highways Network 
– Roads 

• Source for legal road identifications 
• Costings or benefits of road policies 
• Calculating funding allocations 
• For evidence-based policy making 
• Journey and transport planning 
• Emergency service planning 
• Enforcement regulation 
• Traffic statistics 
• School allocation 
• Smart cities 

OS MasterMap Highways Network 
– Routing and Asset Management 
Information (RAMI) 

• Source for legal road identifications 
• Costings or benefits of road policies 
• Calculating funding allocations 
• Policy making 
• Asset management 
• Journey planning, routing, and navigation 
• Emergency service planning 
• Transport planning 
• Enforcement regulation 
• Traffic statistics 
• Delivery 
• Waste management 
• Planned works 
• Projects on the resilience of infrastructure 
• Lane rental schemes 
• Smart cities 

OS MasterMap Highways Network 
– Paths 

• To estimate costs or benefits of road and paths policies 
• Calculating funding allocations 
• Policy making 
• Asset management 
• Journey planning, routing, and navigation 
• Emergency service planning 
• Transport planning 
• Delivery 
• Enforcement regulation 
• School allocation 
• Sustainable travel 
• Planned works 
• Projects on the resilience of infrastructure 
• Smart cities 



 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

2. What do I need to use this data? 

2.1 System requirements 

OS MasterMap Highways Network is designed for use in a geographical information system (GIS). For 
details of Ordnance Survey’s Licensed Partners who can assist you with incorporating the product in their 
systems, please see the 'Software for Mapping' page on the OS website 
(http://www.ordnancesurvey.co.uk/business-and-government/public-sector/mapping-agreements/software-
for-our-products.html). 

Ordnance Survey does not recommend either suppliers or software products, as the most appropriate 
system will depend on many factors, such as the amount of data being taken, resources available within the 
organisation, the existing and planned information technology infrastructure and last but by no means least, 
the applications that the data will be used for. 

However, the following minimum elements will be required in any system: 

• A means of reading the data, either in its native format, or by translating it into a file format or for 
storage in a database 

• A means of storing and distributing the data, perhaps in a database or through a web-based service 

• A way of visualising and / or querying the data, typically a GIS 

2.2 Backup provision of the product 

You are advised to copy the supplied data to a backup medium before following the steps in this guide. 

2.3 Typical data volumes 

For reading purposes, it is recommended that users store the data on a single hard disc. This will speed up 
the ability of your computer to read the data. 

Uncompressed file sizes for the Full Supply of England, Scotland and Wales are as follows: 

Geography Markup Language (GML) 

• OS MasterMap Highways Network – Roads: 29GB 

• OS MasterMap Highways Network – RAMI: 43GB 

• OS MasterMap Highways Network – Paths: 11GB 

  

http://www.ordnancesurvey.co.uk/business-and-government/public-sector/mapping-agreements/software-for-our-products.html
http://www.ordnancesurvey.co.uk/business-and-government/public-sector/mapping-agreements/software-for-our-products.html
http://www.ordnancesurvey.co.uk/business-and-government/public-sector/mapping-agreements/software-for-our-products.html
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GeoPackage (GPKG) 

• OS MasterMap Highways Network – Roads: 8.5GB 

• OS MasterMap Highways Network – RAMI: 3GB 

• OS MasterMap Highways Network – Paths: 5GB 

Vector tiles (MBTiles) 

• OS MasterMap Highways Network – Roads: 1.5GB 

• OS MasterMap Highways Network – Paths: 0.4GB 

2.4 OS MasterMap Highways Network schema files 

Schema files are used to interpret the GML and translate it into a suitable data format by your chosen 
software. However, we are aware that some firewalls will block access to these. In these instances, it is 
suggested that you download the schemas from the OS MasterMap Highways Network GitHub repository 
(https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas). 

https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas
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3. Structure of the supplied data 

3.1 Supply format 

OS MasterMap Highways Network – Roads and OS MasterMap Highways Network – Paths are supplied in 
three formats: Geography Markup Language (GML 3.2.1), GeoPackage and vector tiles. All three formats 
are compressed into a regular zip file (.ZIP). 

OS MasterMap Highways Network – RAMI is supplied in two formats: GML 3.2.1 and GeoPackage. Both 
formats are compressed into a regular zip file (.ZIP). 

3.2 Supply media 

OS MasterMap Highways Network core products (Roads, RAMI, and Paths) are available to Public Sector 
Geospatial Agreement (PSGA) Members, commercial customers and OS Partners through the OS Data 
Hub (https://osdatahub.os.uk/). The products are available as both Full Supply and change-only update 
(COU) and customers can order an area of interest (AOI) or a Managed Great Britain Set (MGBS). The 
products are available as a download for all customers, and as a DVD for customers ordering a MGBS. 

3.3 Coverage 

The products cover Great Britain. Information from the National Street Gazetteer will only be provided 
for England and Wales. Information from the Scottish Street Gazetteer will only be provided for Scotland. 

3.4 Non-geographic chunks 

OS MasterMap Highways Network products will only be supplied as non-geographic chunks. Non-
geographic chunking is a way of dividing up data into chunks that are supplied in separate volumes that have 
a feature count, as opposed to a given geographic National Grid area. For this reason, it is possible for 
features from various geographic locations to appear in one volume and for adjacent features to appear in 
different volumes. 

Non-geographic chunk volumes are designed to be loaded into spatial databases but can be used in a file 
format, provided all chunks are translated or imported into the system at the same time. For information 
on the volume feature counts for each feature type in OS MasterMap Highways Network, please see 
Annex A in the OS MasterMap Highways Network Product Guide. 

  

https://osdatahub.os.uk/
https://osdatahub.os.uk/
https://osdatahub.os.uk/
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3.5 Product packaging 

When a customer receives an order, the product will be packaged as follows: 

• Data folder: Contains the GML, GeoPackage or vector tiles files which make up the ordered product. 

• Doc folder: Contains a summary.gml file which will contain specific information about the customer 
order, including the order number, extent and order type information (‘Full Supply’ or ‘COU’). 

• The GeoPackage and vector tiles formats will be available for GB coverage only, so will not contain 
COU files. 

• Resources folder: Contains the product’s Feature Validation Data Set (FVDS). For further information 
on these resources, please refer to the OS MasterMap Highways Network Product Guide 

3.6 File naming 

3.6.1 GML file names 

The file naming for the OS MasterMap Highways Network GML will be constructed as: 
Highways_ProductName_FeatureType_SupplyType_NullorDelete_volumenumber.gml.gz. 

The name is composed of the following elements: 

• Highways: Identifies that the GML is from the OS MasterMap Highways Network product family 

• ProductName: Is the name of the product that is being supplied, for example, Roads 

• FeatureType: Is the name of the feature type that is being supplied in the GML file, for example, 
RoadLink 

• SupplyType: Is the type of supply the GML is, for example, Full Supply or COU 

• NullorDelete: This will not be present in any GML file names if the GML forms part of a Full Supply. If the 
GML forms part of a COU supply, then 'Delete' will identify if the file contains all the features which 
need removing from the customer holding as a part of the COU application. 

• Volumenumber: Will be the volume number for the file which will be three digits and the first volume 
will be 001 

Examples of the GML file names: 

• Highways_Roads_RoadLink_Full_001.gml.gz 

• Highways_Rrami_AccessRestriction_Full_001.gml.gz 

• Highways_Paths_Maintenance_Full_001.gml.gz 

  



 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

3.6.2 GeoPackage file names 

The file naming for the OS MasterMap Highways Network GeoPackage will be constructed as 
OSMasterMapHighwaysNetworkProductName_gb.gpkg. 

Examples of GeoPackage file names: 

• OSMasterMapHighwaysNetworkRoad_gb.gpkg 

• OSMasterMapHighwaysNetworkPath_gb.gpkg 

• OSMasterMapHighwaysNetworkRAMI_gb.gpkg 

3.6.3 Vector tiles file names 

The file naming for the OS MasterMap Highways Network vector tiles will be constructed as 
OSMasterMapHighwaysNetworkProductName_gb.mbtiles 

Examples of the vector tiles file names: 

• OSMasterMapHighwaysNetworkRoad_gb.mbtiles 

• OSMasterMapHighwaysNetworkPath_gb.mbtiles 

3.7 How do I unzip the GML files? 

The Highways GML data is supplied in a compressed form (gzip). Some software can access these files 
directly; others will require it to be uncompressed. To uncompress the zipped data files (.gz extension), use 
an unzipping utility found on most PCs, for example, WinZip. Open-source zipping / unzipping software can 
be downloaded from the Internet, for example, 7-Zip. 

3.8 How do I unzip the GeoPackage and vector tiles files? 

Before loading the data, you will need to unzip it by using any of the regular zip programs available or via 
the facility within the Windows 10 operating system. 
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4. How do I load the OS MasterMap Highways 
Network products into a GIS? 

This getting started guide focusses solely on loading the product in GML format. For guidance on using the 
products in GeoPackage or vector tiles formats, please see the following two format-specific getting started 
guides, which are available from the 'OS MasterMap Highways Network Product Support' page of the 
OS website (https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-highways-
support): 

• Getting Started with GeoPackage guide 

• Getting Started with Vector Tiles guide 

GML is an XML dialect, which can be used to model geographic features. It was designed by the Open 
Geospatial Consortium (OGC) as a means for people to share information regardless of the applications or 
technology that they use. In the first instance, GML was used to overcome the differences between 
different GIS applications by providing an open standards file format as an alternative to proprietary 
formats. 

The data can be loaded into several GIS. This section describes how to translate the GML and load it into 
some commonly used GIS. However, as the data is based on a relational data model, not all GIS formats 
will support this and storing the data in a relational database is recommended. For more information about 
other GIS that OS MasterMap Highways Network is compatible with, please speak to your OS Relationship 
Manager. 

The common GIS software applications covered in this section are: 

• QGIS 

• ArcMap 

• MapInfo Professional 

• Cadcorp SIS Desktop 

Software for loading into a database: 

• Go Loader – PostGreSQL 

Warning: Some software will successfully read the GML, including both geometry and textual information. However, 
where a data field contains multiplicity, these elements will be ignored. 

  

https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-highways-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-highways-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-highways-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-highways-support
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4.1 QGIS 

These instructions outline how to load OS MasterMap Highways Network into QGIS using the GML file 
you have received. They have been prepared using version 2.14.5 of QGIS Desktop – an open-source GIS 
in which you can create, edit and visualise and publish geographic information. 

You can download QGIS from the QGIS website (http://www.qgis.org/en/site/forusers/download.html). 

4.1.1 Loading and displaying the GML supply 

To load and display GML data in QGIS: 

1. Open an existing project in QGIS or create a new one. 

2. The OS MasterMap Highways Network data can be loaded into QGIS either zipped or unzipped. To 
load the data, select the Add Vector Layer icon (points and lines in the shape of the letter 'V' beside a 
white cross symbol on a green square background). 

 

3. In the Add Vector Layer dialog, in the Source section, click Browse and navigate to the GZ / GML file 
you wish to import. 

Note: If the files do not appear in the browser window, change the file type in the dropdown to Geography Markup 
Language [GML]. 

 

http://www.qgis.org/en/site/forusers/download.html
http://www.qgis.org/en/site/forusers/download.html
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4. After selecting the file, click Open. 

 

Note: Alternatively, you can load the file by dragging and dropping the GZ or GML file into a blank canvas. 

This will open the GML as both vector layers and tables in QGIS, displayed in the Layers Panel. 

 

It also draws the layers in the canvas: 

 

You can add additional layers of OS MasterMap products (for example, OS MasterMap Topography Layer) to give 
context to the data. 
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4.1.2 Translating GML using QGIS 

You can also use QGIS to export OS MasterMap Highways Network data in many different common GIS 
formats. This will allow you to open the files in numerous other GIS applications. 

To translate GML using QGIS: 

1. Right-click on the layer you want to translate and select Save as. 

Note: If you are trying to save layers for more tiles or a national dataset, please bear in mind that you will have to 
save them separately as there is no option for grouping layers. 

2. In the Save Vector Layer as… dialog: 

a. Format: Select your chosen format from the dropdown for further analysis, for example, MapInfo 
TAB or ESRI Shapefile. Tables can also be saved as either a DBF or CSV file. 

b. Format: Select Browse to save your file to a location of your choice. 

c. Click OK to save the data in your chosen format. 

 

3. Repeat steps 1 and 2 for each layer that you want to translate. 
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4.2 ArcMap 

These instructions outline how to load OS MasterMap Highways Network into ArcMap using the GML file 
you have received. They have been prepared using version 10.2 of ArcMap. 

GML data can be now imported as zipped GML (GZ) directly into ArcMap using the Data Interoperability 
tool called ‘Quick Import’. The Interoperability extension is now available at no cost as a part of ArcMap 
from version 10.2. You require internet access when using ‘Quick Import’ tool so the data can access the 
schema attached to the file. 

NOTE: If your version of ArcMap is older than 10.2 and you do not have a licence for Data Interoperability, you will 
have to use translation tools available in QGIS (explained in the previous sub-section) to first translate the GML data 
into ESRI shapefiles, before you can load them in ArcMap. 

You can find more information about the Quick Import tool on the ESRI website 
(http://www.esri.com/software/arcgis/extensions/datainteroperability). 

4.2.1 Loading and displaying the GML supply using the 'Quick Import' tool 

To import GML data into ArcMap using the 'Quick Import' tool: 

1. Open ArcMap. 

2. In the top bar, click the ArcToolbox icon (red toolbox). 

 

3. In the ArcToolbox menu, expand Data Interoperability Tools and double-click on Quick Import. 

 

http://www.esri.com/software/arcgis/extensions/datainteroperability
http://www.esri.com/software/arcgis/extensions/datainteroperability


 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

4. In the Quick Import dialog, select the ellipsis button to the right of the Input Dataset section. 

 

5. In the Specify Data Source dialog, select the ellipsis button to the right of the Format section. 

 

6. In the FME Reader Gallery dialog, select GML SF-0 (Geography Markup Language Simple Features Level SF-0 
Profile), then click OK. 

 

7. Back in the Specify Data Source dialog, in the Dataset section, you should use the ellipsis button to 
navigate to the folder where you saved your GML/GZ file. 

8. In the Select File dialog, select the GML/GZ file and click Open. Make sure that the extensions available 
to load are *.gz or *.gml. 
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9. Leave the rest of the settings as the defaults and click OK in the Specify Data Source dialog. 

 

10. In the Quick Import dialog, select the folder icon to the right of the Output Staging Geodatabase section. 

 

11. In the Output Staging Geodatabase dialog: 

a. Navigate to the folder and select the output Personal Geodatabase for the feature classes to be 
stored in. 

b. Select Geodatabases from the Save as type dropdown. 

c. Click Save. 
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12. Next, select OK in the Quick Import dialog. 

 

The process starts and you will see the process running notification at the bottom of the screen. 

 

When the process is complete, a popup window will appear at the bottom right corner of the screen: 

 

13. Close the ArcToolbox menu. 
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To add data into ArcMap: 

1. Select the Add Data button  (black cross on a yellow diamond) from the top ribbon. 

 

2. In the Add Data dialog, connect to the folder where you saved the Geodatabase by selecting the 

Connect to Folder button  (yellow rectangular folder with a black cross on top of it). 

Note: If you stored the file geodatabase in a folder to which you are already connected, you will not need to connect 
to the folder again. 

 

3. In the Connect to Folder dialog, navigate to the folder and click OK. Select the Highways geodatabase 
that you have created and click Add. 
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4. The component feature classes within the file geodatabase will appear in the Add Data dialog. In this 
example, we only have the RoadLink feature class. Select the OS MasterMap Highways Network 
RoadLink feature class within the file geodatabase, then click Add. 

 

The data appears in the map window in ArcMap un-styled, as shown in the example below: 

 

You can view and analyse the features, as they are, directly from the Geodatabase. You can also save the 
OS MasterMap Highways Network data as ESRI shapefiles or GeoDatabase feature classes. 

  



 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

To save the OS MasterMap Highways Network data as ESRI shapefiles or Geodatabase feature classes: 

1. Right-click on the feature on the Table of Contents, then select Data > Export Data… from the menu. 

 

2. In the Export Data dialog, select the folder icon. 

3. In the Saving Data dialog: 

a. Navigate to the folder where you wish to save your data. 

b. Name: Rename your data accordingly, for example, Soton_Road_Link.shp. 

c. Save as type: Select Shapefile or Geodatabases from the dropdown. 

d. Click Save. 
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4. Leave the rest of the settings in the Export Data dialog as they are and click OK. 

 

5. An ArcMap warning popup window will appear asking if you want to add the exported data to the map 
as a layer; there is no need to do that, so click No. 

 

4.2.2 Loading untranslated GML into ArcMap 

If you are using a more recent version of ArcMap (version 10 onwards), you can open GML files directly in 
ArcMap and view the geometry. 

To load untranslated GML files into ArcMap: 

1. Open ArcMap. 

2. Click the Add Data button  (black cross on top of a yellow diamond) in the top ribbon. 

 

3. In the Add Data dialog, connect to the folder where you saved your translated OS MasterMap 

Highways Network data by clicking the Connect to Folder button  (black cross on top of a yellow 
rectangle). 
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4. In the Connect to Folder dialog, navigate to your folder and click OK. 

 

5. The Add Data dialog will remain open, so you can navigate to your GML files, choose a file to open and 
click Add. 

This will load the geometry into ArcMap for you to inspect. 

6. You can export the geometry to either a shapefile or a geodatabase by right-clicking on a layer in the 
Table of Contents and selecting Data > Export Data… from the menu. 
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4.2.3 Loading translated GML into ArcMap 

If your version of ArcMap is older than version10 or if you do not have access to the Quick Import (Data 
Interoperability) extension, you can use other translation tools such as QGIS (explained in an earlier sub-
section in this guide). This will enable you to first translate the GML for OS MasterMap Highways Network 
data into either a File Geodatabase or ESRI shapefiles before you can load them into ArcMap. However, it 
is recommended to use a File Geodatabase, as a shapefile can only store geometry and not the related 
tables. 

To load translated GML into ArcMap: 

1. Open ArcMap. 

2. To load a geodatabase or shapefile into ArcMap, select the Add Data button  (black cross on top of a 
yellow diamond) in the top ribbon. 

 

3. In the Add Data dialog, connect to the folder where you saved your translated OS MasterMap Highways 

Network data by clicking the Connect to Folder button  (black cross on top of a yellow rectangle). 

 

4. In the Connect to Folder dialog, navigate to your folder and click OK. 
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5. The Add Data dialog will remain open, so you can navigate to the folder containing your data, select the 
elements of the data you wish to open in the map window and click Add. 

 

The OS MasterMap Highways Network features will be added to the ArcMap. 

4.2.4 Creating relationships in an ESRI File Geodatabase 

The OS MasterMap Highways dataset has been created using a relational data model. If you are using a File 
Geodatabase, you can create relationship classes within the Geodatabase. 

Note: Appendix A lists all the relationships between the tables. 

1. Open ArcCatalog. 

2. If you don’t have a connection to the folder containing data, add one now by clicking the Connect to 

Folder button  (black cross on top of a yellow rectangle) from the top ribbon. 

3. In the Catalog Tree: 

a. Navigate to the folder containing your geodatabase. 

b. Right-click on the geodatabase and select New > Relationship Class from the menu. 
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4. In the New Relationship Class dialog: 

a. Give the new relationship class a meaningful name, click on the tables the relationship is between, 
then click Next>. 

In this example, we are creating a relationship between the RoadLink and Road_NetworkRef, which is reflected in 
the name selected for the Name of the relationship class section. 

 

b. Leave the default as Simple (Peer to Peer) Relationship and click Next>. 

c. Leave the default names and select None (no messages propagated), then click Next>. 
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d. As there is more than one reference to the RoadLink, you will need to create a one-to-many 
relationship by selecting 1-M and then click Next>. 

e. You do not need to add attributes, so select No, then click Next>. 

Note: The next step is important as it defines the fields that will be used to link the data together. These 
relationships are described in Appendix A. 

f. For this example, we are using the Primary field in the RoadLink table: TOID; select this from the 
dropdown list. 

g. The Foreign Key in the Road Network Reference table will be RoadLink TOID. Select this from the 
dropdown list, then click Next>. 

h. Click Finish to create the new relationship class. 

 

When you open the data in ArcMap and use the Identify Tool, it will now return all data that forms part of the 
created relationship. 
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4.3 MapInfo Professional 

These instructions outline how to load OS MasterMap Highways Network into MapInfo Professional using 
the GML you have received. They have been prepared using version 15.2.2 of MapInfo. This version of 
MapInfo allows you to convert GML data using the Universal Translator Tool (older versions of MapInfo 
Professional may not have this functionality). 

However, using this tool will only convert the files that contain geometry. If you wish to use the full data 
set, it is recommended that you store the data in either a relational database or a Spatialite or GeoPackage 
data structure, supported from version 12.5 of MapInfo Pro. 

Note: These instructions refer to the 64Bit version. The Universal Translator Tool is the same in the 32Bit version; 
however, the MapInfo menus are slightly different. 

If your version of MapInfo is 12.0.2 or older, you will have to use translation tools available in QGIS 
(explained in an earlier sub-section) to first translate the OS MasterMap Highways Network GML data into 
MapInfo TAB files, before you can load these files into MapInfo. 

If you are bringing in already translated TAB files, start following the instructions from Section 4.3.2. 

4.3.1 Using the Universal Translator Tool to translate GML data to TAB files 

1. Open MapInfo Professional. 

2. On the main Tools tab, select Universal Translator. 

Note: If this is not under the list of ‘Running’ tools in the 'Running' tab, go to the ‘Registered’ tab and scroll down the 
list of available tools until you find it. 

 

3. In the FME Quick Translator dialog, either select File > Translate or click the Translate Data button (side-
by-side upended brown and orange cylinders connected by a green arrow). 
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4. In the Set Translation Parameters dialog: 

a. Reader: Select GML (Geography Markup Language) from the Format dropdown menu. 

 

b. Reader: In Dataset, use the ellipsis button to navigate to the folder where you saved your GML files. 

 

c. Writer: Select MapInfo TAB from the Format dropdown menu. 

d. Writer: In Dataset, use the ellipsis button to navigate to the folder where you want your TAB file 
to be saved. 

e. Leave the rest of the settings as the defaults. 

f. Click OK. 

The translation starts. You will notice comments appearing in FME Quick Translator dialog. When complete, you will 
see a notification saying the 'Translation was SUCCESSFUL'. 



 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

 

5. After you receive a successful translation notification, close the FME Quick Translator dialog. 

4.3.2 Setting the application schema 

One common reason for the translation to fail is that the Universal Translator Tool cannot find the schema 
file used to interpret the GML. If this is the case, the schema file can be added manually. 

To manually add the schema file used to interpret the GML: 

1. Follow Steps 1 to 3 in the sub-section above to open the Universal Translator Tool in MapInfo 
Professional. 

2. In the Set Translation Parameters dialog, click the Parameters… button in the Reader section. 
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3. Halfway down the GML (Geography Markup Language) Parameters dialog, click the ellipsis button to the 
right of the Application Schema box, then navigate to the schema location and select 
GeneralNetwork.xsd. (The schemas can be downloaded from the OS MasterMap Highways Network 
GitHub repository (https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-
Schemas). 

 

4. In the Select Application Schema dialog, click Open and then OK and re-run the translation. 

 

https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-ALL-Schemas
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4.3.3 Opening the translated files in MapInfo Professional 

To open translated TAB files in MapInfo Professional: 

1. In the top ribbon, select the Home tab > Open > Table. 

2. In the Open dialog, use the dropdown menu against 'Look in' to navigate to the folder where you saved 
your TAB files. 

 

Note: If you cannot see your files, select MapInfo (*.tab) from the 'Files of type' dropdown menu. 

3. Select your translated TAB file, then click Open. 

The data will now load into MapInfo Professional without styling: 

 



 
 
OS MASTERMAP HIGHWAYS NETWORK – GETTING STARTED GUIDE 
July 2023 

 

OFFICIAL 
© Ordnance Survey Ltd 2023     
 

4.3.4 Creating and using OGC GeoPackage in MapInfo Professional 

From version 11.5.2 of MapInfo Professional, the SQLite data format has been supported. This is a light-
weight portable data type that allows users to store both geometry and tabular data within the same 
structure. OGC GeoPackage is an extension of this and is supported from MapInfo Professional version 
15.2.2 (version 15.2.2 supports tables with geometry and version 21 supports all GeoPackage content). 
Both formats can be created using FME workbenches. 

To open a GeoPackage for use in MapInfo Professional: 

1. In the top ribbon, select the Home tab > Open > Table. 

2. In the Open dialog: 

a. Change the Files of type dropdown to GeoPackage (.gpkg). 

Note: You will also see an option in the 'Files of type' dropdown for SQLite, which can be opened in a similar way. 

b. Use the dropdown menu against 'Look in' to navigate to the folder where you saved your 
GeoPackage file. 

c. Click Open. 

A list of available tables appears in the Select One or More Tables to Open dialog. 

3. In the Select One or More Tables to Open dialog: 

a. Select the tables you wish to open. 

b. If your table contains geometry, you can set the default style by selecting the Style tab. 

c. Chose the geometry type (Point, Line or Area) and select a style. 

d. Click OK to open the tables in MapInfo Professional. 
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MapInfo Professional will create a TAB file for the data you have selected. The file will open within the Explorer 
panel and the map window and will be ready for you to work with. 
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4.4 Cadcorp SIS Desktop 

The following instructions explain how to display and build a structured topological dataset using OS 
MasterMap Highways Network data in Cadcorp SIS Desktop. For the purposes of this guide, the version of 
Cadcorp SIS Desktop used is 9.1.1610. 

There are several ways to load OS MasterMap Highways Network data into Cadcorp SIS Desktop: 

• Using OS MasterMap Highways Network utility. This allows you to visualize the highways data, and 
carry out network analysis using the SIS Desktop Routing Tools. 

• Using Drag & Drop to visualize the highways data, which does not create a routable network. 

• Using the OS (GB) Networks Manager to load the highways data and create a fully routable network 
dataset. 

• Optionally, add OS Paths data to that dataset. 

Each method is dealt with in turn, in the following sections. 

4.4.1 Loading Highways Data with OS MasterMap Highways Network 

OS MasterMap Highways Network allows Highways data supplied directly from Ordnance Survey to be 
loaded into SIS. This option should be used for the initial visualization of the Highways data. 

1. On the main Cadcorp SIS Desktop screen, select Add Overlay > Ordnance Survey (GB) > OS (GB) 
Transport Network. 

2. Click Next to display the Ordnance Survey MasterMap Highways Network dialog. 

3. Browse to the root folder containing the OS (GB) MasterMap Highways Network files. 
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The example below shows the OS (GB) MasterMap Highways Network folder that contains the following .gml files: 

 

4. Select the folder and click Finish. 

The following map will be displayed: 

 

This layer is topologically structured and can be used with the SIS Desktop Routing Tools, for network analysis, 
including Point to Point routing based on road classification, as well as the underlying topology. 

To avoid loading the .gml files every time this network is required, we recommended you use the Ordnance Survey 
MasterMap Highways Network Manager to load Highways data into a single topologically structured file, as 
described below. 
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4.4.2 Loading Highways Data using Drag & Drop 

You can also load Highways data into SIS Desktop by simply dragging and dropping a Highways .gz or .gml 
file as supplied by Ordnance Survey into the SIS Desktop window. 

 

Note: This method will not create a routable network in SIS Desktop and will not apply any of the routing 
information or U-turn restrictions. It is a method to simply display the data in SIS Desktop. To obtain a routable 
network, you must use the method described in the next section. 

4.4.3 Loading Highways Data using Ordnance Survey (GB) Networks Manager 

To build the Highways data into a single, topological structured .bds file, the data should be processed using 
the Ordnance Survey (GB) Networks Manager. 

1. Click File > Utilities > Ordnance Survey (GB) and select Cadcorp SIS Network Manager. 

The Cadcorp SIS Network Manager dialog opens. 
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2. Select OS (GB) Transport Network. 

3. Use the file browser to navigate to the location of the source files and click Next. 

 

The number of .gz/.gml files selected for loading will be shown in the dialog above. 

4. If required, check the Import network in 2D option.  This will disregard the z value in the Highways data 
which can sometimes distort snapping. 

5. Click Next. 
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6. To create a new .bds file to hold the topological data from the .gml files, navigate to an appropriate 
location where you want to create the .bds file, then enter a filename and click Save. 

7. In the next window, check the tickbox(es) for the required processing options. For network analysis, it 
is recommended that both options are applied to prevent routing behaving illogically. 

 

8. In the preceding dialog, you also have the option of saving and exporting the network to an OSRM 
(Open Source Routing Machine) database which can be used for exceptionally fast routing in SIS 
Desktop. 

9. Click Next > Load to begin loading the data. 
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10. When loading is complete (shown by the confirmation message in the log), click Close.  

 

The .bds file is created in the chosen location. 
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4.4.4 Adding OS MasterMap Highways Network Paths Data 

If required, you can also add OS MasterMap Highways Network Paths data to the OS MasterMap Highways 
Network data file you created in the previous section. 

1. On the Cadcorp SIS Network Manager dialog, select Add Paths Data. 

2. Use the file browser to navigate to the Highways data file (usually a .bds file) and click Next. 

 

3. Select the OS MasterMap Highways Network Path data you would like to add to the .bds file. (Click on 
the three dots to open the file browser). 
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You can also choose to maintain a separate copy of the .bds file by the option in the preceding dialog. 

4. Click Next > Load to begin loading the OS MasterMap Highways Network Paths data. 

 

A message is displayed in the preceding dialog to confirm that the Paths data has finished loading. 
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5. Using Snowflake to load the data into a database 
Snowflake Software provide standard project templates for various OS products, so that users can load the 
data to a standard data model with a minimum of effort to a data model that meets the needs of most end-
users. 

Snowflake have created a new standard project to support the new OS MasterMap Highways Network 
dataset. This can be downloaded from the Snowflake support portal. 

The project also includes columns to help support styling / MapInfo styling if needed. 

1. Open GO Loader, File/Download Templates, and download the new standard GO Loader project for 
Highways, from the Customer portal (Products/GO Loader/Resources/Project Templates). 

2. Save the file to your drive and unzip it. 

 

3. In GO Loader, open the new extracted OS_Highways.glp GO Loader Standard project (or drag it into 
the Project File area of the screen). 

 

4. Select the Loader Configuration tab to set your target database details. 
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5. Set a directory location on your hard drive for ‘load lists’ (choose any valid local location). 

 

6. Create all the tables defined in the GO Loader Highways project (ideally choose a new database or 
schema without other existing tables). 

 

7. Load all your Highways data files. 
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8. Create the Spatial Indexes and other indexes. 
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Annex A: Relationships between Highways tables 
The following table is intended for use with the procedures described in Section , Creating relationships in an ESRI File Geodatabase, of this guide: 

Table 2. Relationships between Highways tables. 

Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

RoadLink Linear Network RoadLink Y TOID N/A N/A 

RoadLinkAlternativeIdentifier Linear Network RoadLink N 
TOID (id in 
GML/technical 
spec) 

RoadLink TOID 

RoadLinkFormsPartOf Linear Network RoadLink N TOID Road or Street formsPartOf - Will be either Road 
TOID or Street USRN 

RoadLink_TopoTOIDRef Linear Network RoadLink N TOID Topo Area 
RelatedRoadAreaTOID - Will be 
the TOID of the Topo area(s) 
that represent the RoadLink. 

AccessRestriction_NetworkR
ef 

Routing and 
Asset 
Management 
Information 

AccessRestriction N TOID RoadLink RoadLink_TOID - The TOID in 
the RoadLink table 

AccessRestriction 

Routing and 
Asset 
Management 
Information 

AccessRestriction N TOID 

AccessRestriction_N
etworkRef, 
AccessRestriction_In
clusion, 
AccessRestriction_Ex
emption 

TOID 

AccessRestriction_Inclusion Routing and 
Asset 

AccessRestriction N TOID AccessRestriction TOID 
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Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

Management 
Information 

AccessRestriction_Exemption 

Routing and 
Asset 
Management 
Information 

AccessRestriction N TOID AccessRestriction TOID 

Hazard_NetworkRef 

Routing and 
Asset 
Management 
Information 

Hazard Y TOID RoadLink and 
RoadNode 

RoadLink_TOID and RoadNode 
_TOID - The TOID in the 
respective tables 

Hazard 

Routing and 
Asset 
Management 
Information 

Hazard Y TOID Hazard_NetworkRef TOID 

Hazard_NodeReference_Link
Reference 

Routing and 
Asset 
Management 
Information 

Hazard N TOID RoadLink RoadLink_TOID 

RestrictionForVehicles_Netw
orkRef 

Routing and 
Asset 
Management 
Information 

VehicleRestriction, 
RestrictionForVehic
les 

N TOID RoadLink and 
RoadNode 

RoadLink_TOID and RoadNode 
_TOID - The TOID in the 
respective tables 

RestrictionForVehicles 

Routing and 
Asset 
Management 
Information 

VehicleRestriction, 
RestrictionForVehic
les 

Y TOID RestrictionForVehicle
s_NetworkRef TOID 
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Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

RestrictionForVehicles_Node
Reference_LinkReference 

Routing and 
Asset 
Management 
Information 

VehicleRestriction, 
RestrictionForVehic
les 

N TOID RoadLink RoadLinkTOID 

Road Linear Network Road N TOID Road_NetworkRef TOID 

Road_NetworkRef Linear Network Road N TOID RoadLink RoadLink_TOID - Is the TOID of 
the RoadLink table. 

RoadNode Linear Network RoadNode Y TOID N/A N/A 

RoadNode_RelatedRoadArea Linear Network RoadNode N TOID Topo Area 
RelatedRoadAreaTOID - Will be 
the TOID of the Topo area(s) 
that represent the RoadNode. 

Street_NetworkRef Linear Network Street N USRN RoadLink RoadLink_TOID - Will be the 
TOID of the RoadLink table. 

Street Linear Network Street N USRN Street_NetworkRef USRN 

Structure_NetworkRef 

Routing and 
Asset 
Management 
Information 

Structure N TOID RoadLink and 
RoadNode 

RoadLink_TOID and RoadNode 
_TOID - The TOID in the 
respective tables 

Structure 

Routing and 
Asset 
Management 
Information 

Structure Y TOID Structure_NetworkR
ef TOID 

Structure_NodeReference_Li
nkReference 

Routing and 
Asset 
Management 
Information 

Structure N TOID RoadLink RoadLink_TOID 
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Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

TurnRestriction_NetworkRef 

Routing and 
Asset 
Management 
Information 

TurnRestriction N TOID RoadLink RoadLink_TOID - The TOID in 
the RoadLink table 

TurnRestriction 

Routing and 
Asset 
Management 
Information 

TurnRestriction N TOID 

TurnRestriction_Net
workRef, 
TurnRestriction_Exe
mption, 
TurnRestriction_Inclu
sion 

TOID 

TurnRestriction_Exemption 

Routing and 
Asset 
Management 
Information 

TurnRestriction N TOID TurnRestriction TOID 

TurnRestriction_Inclusion 

Routing and 
Asset 
Management 
Information 

TurnRestriction N TOID TurnRestriction TOID 

Maintenance Point 

Routing and 
Asset 
Management 
Information 

Maintenance Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Maintenance Line 

Routing and 
Asset 
Management 
Information 

Maintenance Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Maintenance Area Routing and 
Asset 

Maintenance Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 
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Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

Management 
Information 

Maintenance No Geometry 

Routing and 
Asset 
Management 
Information 

Maintenance N ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Reinstatement Point 

Routing and 
Asset 
Management 
Information 

Reinstatement Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Reinstatement Line 

Routing and 
Asset 
Management 
Information 

Reinstatement Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Reinstatement Area 

Routing and 
Asset 
Management 
Information 

Reinstatement Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Reinstatement No Geometry 

Routing and 
Asset 
Management 
Information 

Reinstatement Y ID Street Reference_To_StreetUSRN - The 
USRN in the Street table 

Junction Linear Network RoadJunction N TOID RoadNode 
TOID, RoadNode_TOIDs (the 
junction can reference back to 
multiple road nodes) 

Highways Dedication Routing and 
Asset 

Dedication Y ID Road, Street or Path 
NetworkRef - TOID in RoadLink 
and PathLink table and  USRN in 
the Street table 
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Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

Management 
Information 

Special Designation Point 

Routing and 
Asset 
Management 
Information 

SpecialDesignation Y networkRef Street NetworkRef - USRN in the Street 
table 

Special Designation Line 

Routing and 
Asset 
Management 
Information 

SpecialDesignation Y networkRef Street NetworkRef - USRN in the Street 
table 

Special Designation Area 

Routing and 
Asset 
Management 
Information 

SpecialDesignation Y networkRef Street NetworkRef - USRN in the Street 
table 

Special Designation No 
Geometry 

Routing and 
Asset 
Management 
Information 

SpecialDesignation N networkRef Street NetworkRef - USRN in the Street 
table 

Ferrylink Linear Network FerryLink Y TOID N/A N/A 

Ferrylink Linear Network FerryLink N TOID FerryNode FerryNode_TOID (one for 
startNode and one for endNode) 

FerryNode Linear Network FerryNode Y TOID N/A N/A 

FerryTerminal Linear Network FerryTerminal N 

refToFuncation
alSite,roadNod
eRef, 
pathNodeRef 

Road Node, Path 
Node and Functional 
Site 

TOID 
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Table Specification GML file Contains 
geometry 

Column ID 
Primary Relates to Column ID Foreign 

PathLink Paths PathLink Y TOID N/A N/A 

PathLinkAlternativeIdentifier Paths PathLink N TOID PathLink TOID 

PathLinkFormsPartOf Paths PathLink N TOID Path or Street formsPartOf - Will be either Path 
TOID or Street USRN 

PathLink_TopoTOIDRef Paths PathLink N TOID Topo Area 
RelatedPathAreaTOID - Will be 
the TOID of the Topo area(s) 
that represent the PathLink. 

PathLink Paths PathLink N TOID PathNode PathNode_TOID (one for 
startNode and one for endNode) 

Path Paths Path N TOID Path_NetworkRef TOID 

Path_Ref_PathLink Paths Path N TOID PathLink PathLink_TOID - Is the TOID of 
the PathLink table. 

PathNode Paths PathNode Y TOID N/A N/A 

PathNode_RelatedRoadArea Paths PathNode N TOID Topo Area 
RelatedPathAreaTOID - Will be 
the TOID of the Topo area(s) 
that represent the PathNode. 

ConnectingLink Paths ConnectingLink Y TOID PathNode and 
ConnectingNode TOID 

ConnectingNode Paths ConnectingNode Y TOID RoadLink TOID 
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Annex B: Product support links 

Guides 

You can find additional information and documentation about the product on the 'OS MasterMap Highways 
Network Technical Information' page on the OS website (https://www.ordnancesurvey.co.uk/products/os-
mastermap-highways-network-roads#technical): 

We recommend that you read the following guides: 

• OS MasterMap Highways Network – Product Guide 

• OS MasterMap Highways Network – Roads – Technical Specification 

• OS MasterMap Highways Network – Routing and Asset Management Information – Technical Specification 

• OS MasterMap Highways Network – Paths – Technical Specification 

• Getting Started with GeoPackage 

• Getting Started with Vector Tiles 

• Guide to Routing for the Public Sector 

Stylesheets 

• Predefined stylesheets for OS MasterMap Highways Network are available for download from the 
Ordnance Survey OS-MasterMap-Highways-Network-stylesheets GitHub repository 
(https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-stylesheets). 

• To download a ZIP containing all stylesheets, navigate to Code > Download ZIP. 

https://www.ordnancesurvey.co.uk/products/os-mastermap-highways-network-roads#technical
https://www.ordnancesurvey.co.uk/products/os-mastermap-highways-network-roads#technical
https://www.ordnancesurvey.co.uk/products/os-mastermap-highways-network-roads#technical
https://www.ordnancesurvey.co.uk/products/os-mastermap-highways-network-roads#technical
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-stylesheets
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-stylesheets
https://github.com/OrdnanceSurvey/OS-MasterMap-Highways-Network-stylesheets
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