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Purpose of this document 

This document provides information about and insight into the OS MasterMap Topography Layer product 
and its potential applications. For information on the contents and structure of OS MasterMap Topography 
Layer, please refer to the Overview and Technical Specification. 

The terms and conditions on which OS MasterMap Topography Layer is made available to you and your 
organisation are contained in that Ordnance Survey customer contract. Please ensure your organisation has 
signed a valid current customer contract to be able to use OS MasterMap Topography Layer. 

We may change the information in this document at any time, giving you the notice period set out in your 
contract. We do not accept responsibility for the content of any third-party websites referenced or 
accessed in or through this document. 

This document has been screened according to Ordnance Survey's Equality Scheme. If you have difficulty 
reading this information in its current format and would like to find out how to access it in a different 
format (braille, large print, computer disk or in another language), please contact us on: 
+44 (0)3456 05 05 05. 

Copyright in this document 

© Ordnance Survey Limited 2022. This document (including for the avoidance of doubt, any mapping 
images reproduced within it) is protected by copyright and apart from the rights expressly granted within 
this document to use the content, all rights are reserved. Any part of this document may be copied for use 
internally in your organisation or business so that you can use OS MasterMap Sites Layer under the terms 
of your licence (but not otherwise). 

No part of this document may be reproduced or transmitted in any form or by any means (including 
electronically) for commercial exploitation, onward sale or as free promotional material without getting the 
written consent of Ordnance Survey beforehand. 

Trade marks 

Ordnance Survey, OS, the OS Logos, OS MasterMap and OSMM are registered trade marks, and 
OS MasterMap Topography Layer is a trade mark of Ordnance Survey, Britain’s mapping agency. 

Contact details 

OS website ‘Contact us’ page (https://www.ordnancesurvey.co.uk/contact-us) 

https://www.ordnancesurvey.co.uk/contact-us
https://www.ordnancesurvey.co.uk/contact-us
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1. Obtaining OS MasterMap Topography Layer data 
This getting started guide shows you how to load OS MasterMap Topography Layer into several commonly 
used geographical information system (GIS) applications. 

1.1 Product formats 

OS MasterMap Topography Layer is available the following formats: 

• GeoPackage (area of interest – AOI – only) 

• Vector tiles (MBTiles) 

• Geography Markup Language (GML) 2.1.2 
 
The GML download ZIP package contains a GZ (.gz) file, which does not require extraction and 
contains multiple GML (.gml) files.  

The GML data is supplied in 5km2 tiles, but features are not clipped at the tile edges, resulting in what is 
called “hairy” tiles. All tiles contain six elements: 

• Cartographic Symbol 

• Cartographic Text 

• Boundary Line 

• Topographic Point 

• Topographic Line 

• Topographic Area 

OS MasterMap Topygraphy Layer can be downloaded from the OS Data Hub (https://osdatahub.os.uk/). 

1.2 Media 

OS MasterMap Topygraphy Layer is not available via hard media supply.  

1.3 Using GeoPackage and vector tile formats 

This getting started guide focuses on using the product in GML and shapefile format.  

For guidance on using the product in GeoPackage or vector tiles formats, please see the following generic 
getting started guides, which are available on the OS MasterMap Topography Layer Product Support page 
on the OS website (https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-
topography-support): 

https://osdatahub.os.uk/
https://osdatahub.os.uk/
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-topography-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-topography-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-topography-support
https://www.ordnancesurvey.co.uk/business-government/tools-support/mastermap-topography-support
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• Getting Started with GeoPackage (https://www.ordnancesurvey.co.uk/documents/getting-started-with-
geopackage.pdf).  

• Getting Started with Vector Tiles (https://www.ordnancesurvey.co.uk/documents/user-guides/getting-
started-with-vector-tiles-v1.0.pdf). 
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2. QGIS 
These instructions are based on QGIS version 3.22.4 and assume you have set the default coordinate 
reference system to British National Grid (EPSG 27700). 

2.1 Loading and displaying the GML supply 

There are two ways to load the GML supply into QGIS: You can use drag and drop or the Data Source 
Manager. 

2.1.1 Using drag and drop 

To load the GML supply using drag and drop: 

1. Open an existing QGIS project or create a new one.  

2. In the file system on your computer system (for example, in Windows Explorer), select the GML data 
(.gz file). 

3. Drag and drop the file directly into the QGIS UI.  

4. In the Select Items to Add dialog: 
 
If you use multiple screens, this dialog may open on another screen. 

a. Select each required layer or click Select All to select all layers. 

b. Check the Add layers to a group option. 

This groups the layers by OSMM Topography Layer tile reference. 

c. Click Add Layers. 

 
Figure 1: QGIS Select Items to Add dialog 
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The GML data will now display in both the Layers panel and the map area. 

 

2.1.2 Using Data Source Manager 

To load the GML supply into QGIS using Data Source Manager: 

1. Open an existing project or create a new one.  

2. In the Layer menu, click Data Source Manager. 

 
Figure 2: QGIS UI showing Layer > Data Source Manager action 

3. In the Data Source Manager dialog: 

a. Select Vector from the data menu on the left. 

b. In Source > Vector Dataset(s), click ‘…’, navigate to and select the GML on your computer. 

c. Click Add. 
 

 

Figure 3: QGIS Data Source Manager dialog showing Vector > Source > Vector Dataset(s) field. 
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4. In the Select Items to Add dialog: 
 
If you use multiple screens, this dialog may open on another screen. 

a. Select each required layer or click Select All to select all layers. 

b. Check the Add layers to a group option. 

This groups the layers by OSMM Topography Layer tile reference. 

c. Click Add Layers. 

 
Figure 4: QGIS Select Items to Add dialog 

 

The data will now display in both the Layers panel and the map area. 

2.2 Layer order and rendering 

Data is typically grouped by tile reference in the Layers panel. If you open two or more OSMM Topography 
Layer layers simultaneously (for example, TopographicArea and BoundaryLine), you may need to reorder the 
layers to see the data correctly. 

You can reorder layers using drag and drop. We recommend the following layer order: CartographicText, 
CartographicSymbol, TopographicPoint, BoundaryLine, TopographicLine and TopographicArea.  
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Figure 5: QGIS Layers panel showing recommended layer order 

 

2.3 GML data limitations 

Using GML data in QGIS is not always the best option. You should consider converting your data to 
another format (for example, shapefile) for the following reasons: 

• When working with multiple tiles of 5km2 OSMM Topography Layer data, GML data does not always 
merge seamlessly.  

• Rendering performance of GML data in QGIS is not as good as other formats, because GML data 
cannot be spatially indexed.  

The sections that follow show you how to convert GML data to shapefile and how to apply a spatial index 
to shapefiles. 
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2.3.1 Converting GML to shapefile 

To convert GML to shapefile in QGIS: 

1. In the Layers panel, right-click on the layer you want to convert and click Export > Save Features As.... 

 

Figure 6: QGIS Layers panel showing Export > Save Feature As action 

2. In the Save Vector Layer as… dialog: 

a. Format: Select ESRI Shapefile. 

b. File name: Click …, navigate to the folder in which you want to store the shapefile, name the file, 
and click Save. 

c. Check the Add saved file to map option. 

d. Click OK. 
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Figure 7: QGIS Save Vector As dialog showing GML to shapefile conversion 

 
You can watch the export progress in the blue progress bar at the bottom of the QGIS UI. When the process is 
complete, the shapefile layers will display in the Layers panel and the map area. 

3. Repeat steps 1 - 2 above for each layer (for example, TopographicLine, CartographicText…) that you want 
to convert. 

2.3.2 Applying a spatial index to shapefiles 

When working with shapefiles, we recommend you apply a spatial index to the data, particularly when 
loading large or national sets of data. This significantly improves performance when rendering and panning 
the data.  
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To apply a spatial index to a shapefile in QGIS:  

1. In the Layers panel, right-click on the shapefile layer you want to index and click Properties in the 
context menu. 

 

Figure 8: QGIS Layers panel showing Properties option in the context menu 
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2. In the Layer Properties dialog: 

a. Select Source in the navigation menu on the left. 

b. In Geometry click Create Spatial Index. 

c. Click OK to close the confirmation dialog. 

d. Click Apply and then OK. 

 

Figure 9: QGIS Layer Properties dialog showing Source > Geometry > Create Spatial Index option 

Your shapefile layer will now be spatially indexed; this improves rendering and querying performance.  

3. Repeat steps 1 and 2 above for each layer you want to create an index for (for example, 
TopographicLine, CartographicText…). 
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3. ArcGIS Pro 
The following instructions are based on ArcGIS Pro version 2.8.1 and assume that you have access to and 
knowledge of the UK Data Loader and the Data Interoperability Extension to convert the supplied GML 
into a suitable ArcGIS Pro format. 

Note, if you do not have access to the UK Data Loader and the Quick Import (Data Interoperability) extension, use 
the translation tools available in FME or QGIS to convert the GML data to shapefiles, or import it into an ESRI 
Geodatabase before loading them into ArcGIS Pro. 

3.1 Loading and displaying the GML supply using UK Data Loader 

The UK Data Loader is an ArcGIS toolbox. It contains a set of tools that primarily allow loading of 
Ordnance Survey data into an ArcGIS workspace. 

If the UK Data Loader is not already installed, we recommend you add the folder containing the toolbox 
into your documents. More information on installing the UK Data Loader is available in ESRI’s UK Data 
Loader User Guide. This guide also provides instructions for processing Change Only Updates (COU) for 
OSMM Topography Layer. 

Using the UK Data Loader involves two steps: Converting the GML supply and loading the converted file 
geodatabase into ArcGIS Pro.  

3.1.1 Converting the GML supply to file geodatabase 

Note: Before you start, you need either an existing file geodatabase (.gdb) or a database connection to load the files 
into. 

To load the GML data into ArcGIS Pro using the UK Data Loader: 

1. Open an existing project or create a new one.   
 
You may want to select a basemap for backdrop context.  

  

https://www.arcgis.com/home/item.html?id=7ae5c49bf3ab4c55a31f85fd935aa1a4
https://www.arcgis.com/home/item.html?id=7ae5c49bf3ab4c55a31f85fd935aa1a4
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2. From the View tab, select Catalog View. 

 

Figure 10: ArcGIS Pro UI showing View > Catalog View option 

3. In the Catalog view, navigate to the location in which your UK Data Loader toolbox is saved.  
 
You may need to connect to the relevant folder using the Add Folder option in the Insert tab. 

 

Figure 11: ArcGIS Pro UI showing saved UK Data Loader toolbox in Catalog View 
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4. Open the toolbox, navigate to OS MasterMap Topography Layer > Load OSMM Topography Data, right-
click on the script, and click Open in the context menu. 

 

Figure 12: ArcGIS Pro UI showing the Open action in Catalog view 

5. This will open the Geoprocessing panel in which you can set the parameters for running the script: 

a. Source Data Folder: Navigate to and select the GML file(s) required. 

b. Existing Destination Workspace: Navigate to and select the pre-existing file geodatabase (.gdb) 
folder to load the data into. 

c. Logging File Folder: Navigate to and select a folder into which to save the log that will be created 
during data processing.  
 
This is important because any error messages will be captured here. These may help identify issues. 

d. Feature Class / Table Prefix: Enter a prefix for your tables (for example, Topo_). 

e. Create Annotation Line Features: Check this option if it is available and required. 
 
This checkbox option is only available in older versions of ArcGIS Pro/UK Data Loader.  
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Figure 13: ArcGIS Pro Geoprocessing panel showing Parameters tab options 
 

6. Click  (Run button) at the bottom of the panel to process the data.  
 
This may take some time, depending on the number of 5km2 OSMM Topography Layer tiles being processed. 

On completion, the OSMM Topography Layer data will be saved to the destination file geodatabase, which 
can then be loaded into the workspace by following the instructions in the next section. 

3.1.2 Loading and displaying data from the file geodatabase 

Having converted your GML data to file geodatabase using the UK Data Loader (or other tools listed in 
this guide), you can now load the OSMM Topography Layer GDB into your ArcGIS Pro workspace. 

To load and display the file geodatabase in an ArcGIS Pro workspace:  

1. Open an existing project or create a new one.  
 
You may want to select a basemap for backdrop context.  
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2. From the Map tab, select Add Data. 

 

Figure 14: ArcGIS Pro UI showing Map > Add Data option 

3. In the Add Data dialog, navigate to and select the file geodatabase (.gdb) containing the OSMM 
Topography Layer data, and then click OK. 

 

Figure 15: ArcGIS Pro Add Data dialog showing selection of the file geodatabase 
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4. In the selected file geodatabase (.gdb) select the feature classes that you want to load and then click OK.  
 
You can select multiple feature classes at once to save repeating these steps for all the OSMM Topographic 
Layer features. 

 

Figure 16: ArcGIS Pro Add Data dialog showing selection of the OSMM Topography Layer feature classes 

Your OSMM Topography Layer feature classes will now appear in both the Contents panel and map area.  
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You may need to reorder the layers to see the data correctly. You can reorder layers using drag and drop. 
We recommend the following layer order: CartographicText, CartographicSymbol, TopographicPoint, 
BoundaryLine, TopographicLine and TopographicArea. 

 

Figure 17: ArcGIS Pro UI showing OSMM Topography Layer layers in the Contents panel 

3.2 Loading and displaying shapefiles 

As an alternative to using the UK Data Loader, you can load OSMM Topography Layer shapefiles directly 
into your ArcGIS Pro workspace. You need to first convert your GML data to shapefile.  

Translation tools available in FME and QGIS to convert the GML data to shapefiles. 

To load and display shapefiles in an ArcGIS Pro workspace: 

1. Open an existing project or create a new one.  
 
You may want to select a basemap for backdrop context.  
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2. From the Map tab, select Add Data. 

 

Figure 18: ArcGIS Pro UI showing Map > Add Data option 

3. In the Add Data window, navigate to and select the shapefiles (.shp) containing the OSMM Topography 
Layer data, and then click OK. 
 
You can select multiple shapefiles at once to save repeating these steps for all the OSMM Topographic Layer 
features. 

 

Figure 19: ArcGIS Pro Add Data dialog showing selection of the OSMM Topography Layer shapefiles 

Your OSMM Topography Layer shapefiles will now display in both the Contents panel and map area.  
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You may need to reorder the layers to see the data correctly. You can reorder layers using drag and drop. 
We recommend the following layer order: CartographicText, CartographicSymbol, TopographicPoint, 
BoundaryLine, TopographicLine and TopographicArea. 

 

Figure 20: ArcGIS Pro UI showing OSMM Topography Layer layers in the Contents panel 
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4. ArcMap 
These instructions are based on ArcMap version 10.8.1. and assume you have set the default coordinate 
reference system to British National Grid (EPSG 27700). 

Note: if your ArcMap is older than version 10.0, or if you do not have access to the Quick Import (Data 
Interoperability) extension, use the translation tools available in FME and QGIS to convert the GML data to 
shapefiles. 

4.1 Loading and displaying the GML supply using the Quick Import 
tool 

You can import GML data into ArcMap using the Quick Import tool that converts the GML into file 
geodatabase (.gdb). 

Note: Due to the large file size, some 5km2 tiles (especially within larger cities) may take time to process.  

To load GML data into ArcMap: 

1. Open ArcCatalog and click and  (ArcToolbox icon) in top toolbar to open the ArcToolbox.  

 

Figure 21: ArcMap ArcCatalog panel highlighting the ArcToolbox icon 

1. In ArcToolbox, expand Data Interoperability Tools and click Quick Import.  

 

Figure 22: ArcMap’s ArcToolbox showing Data Interoperability Tools > Quick Import option 
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2. In the Quick Import dialog, click … (next to the Input Dataset field), and navigate to and select your OS 
MasterMap Topography GML data.  

 

Figure 23: ArcMap Quick Import dialog 

3. In the Specify Data Source dialog: 

a. Format: GML SF-0 (Geography Markup Language Simple Features Level SF-0 Profile) will be detected 
automatically.  

b. Coord. System: Enter British_National_Grid or click … and select it in the dialog.   

c. Click OK. 

 

Figure 24: ArcMap Specify Data Source dialog 
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4. In the Quick Import dialog: 

a. Output Staging Geodatabase field: Click  (file browser icon), navigate to and name the file 
geodatabase (.gdb) folder, and click Save. 

b. Click OK to start the Quick Import. 

 

Figure 25: ArcMap Quick Import dialog showing example input and output information 

When the import process is complete, a message will display in ArcCatalog. 

To display the GML data in ArcMap: 

1. Open an existing project or create a new one.  

2. In the top toolbar, click  (Add Data icon). 

 

Figure 26: ArcMap UI showing Add Data action 
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3. In the Add Data dialog: 

a. Navigate to the file geodatabase created in the previous procedure.  
 
If the relevant folder does not display, click  (Connect to Folder icon) and navigate to the file geodatabase 
folder from there. 

b. Select the layers you want to load.  
 
You can select multiple layers at the same time to save repeating these steps for each layer in the file 
geodatabase.  

c. Click Add. 

 

Figure 27: ArcMap Add Data dialog showing selected OSMM Topography Layer file geodatabase layers 

 
Your geodatabase layers will now display in both the Table of Contents panel and the map area. 
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4.2 Loading and displaying shapefiles 

As an alternative to using ArcMap’s Quick Import tool (previous section), you can convert your GML data 
to shapefile using FME and QGIS, and then add the shapefiles directly to ArcMap.  

To load shapefiles into ArcMap 

1. Open an existing project or create a new one. 

2. In the top toolbar, click  (Add Data icon). 

 

Figure 28: ArcMap UI showing Add Data action 

3. In the Add Data dialog: 

a. Navigate to the shapefiles you want to load.  
 
If the relevant folder does not display, click  (Connect to Folder icon) and navigate to the file geodatabase 
folder from there. 

b. Select the shapefiles that you want to load.  
 
You can select multiple layers at the same time to save repeating these steps for each shapefile.  

c. Click Add. 
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Figure 29: ArcMap Add Data dialog showing selected OSMM Topography Layer shapefile layers 

Your shapefiles will now appear in both the Table of Contents panel and the map area.  

You may need to reorder the layers to see the data correctly. You can reorder layers using drag and drop. 
We recommend the following layer order: CartographicText, CartographicSymbol, TopographicPoint, 
BoundaryLine, TopographicLine and TopographicArea. 

 

Figure 30: ArcMap Table Of Contents showing OSMM Topography Layer layers  
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5. Cadcorp SIS Desktop Express 
These instructions are based on Cadcorp SIS Desktop Express 9.0.2511 and assume you have set the 
default coordinate reference system to British National Grid (EPSG 27700). These instructions also work 
for the fully licenced version of Cadcorp SIS Desktop. 

5.1 Loading and displaying the GML supply 

There are two ways to load the GML supply into Cadcorp SIS Desktop: You can use drag and drop or add 
and overlay. 

5.1.1 Using drag and drop 

To load and display the GML supply using drag and drop: 

1. Open an existing project or create a new one. 

2. In the file system on your computer system (for example, in Windows Explorer), select the GML data 
(.gz file). 

3. Drag and drop the file directly into the Map area in Cadcorp SIS Desktop. 
 
Data processing will begin automatically. You can monitor the progress by watching the spinning blue circle in 
the bottom left of the UI. 
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When processing is complete, the data will display in the Maps panel and Map area. 

Cadcorp produces their own OS MasterMap Topography styling, which automatically styles your OMMM 
Topography data. If you cannot see your data, zoom to > 1:4,000 scale and it should become visible. 

 

Figure 31: Cadcorp SIS Desktop showing loaded OSMM Topography Layer GML data 
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5.1.2 Adding an overlay 

To load and display the GML supply by adding an overlay: 

1. Open an existing project or create a new one. 

2.  From the Home tab, click Add Overlay. 

 

Figure 32: Cadcorp SIS Desktop UI showing Home > Add Overlay action 

3. In the Overlay Types dialog: 

a. Click Files in the left navigation menu. 

b. Click File in the options on the right. 

c. Click Next>. 

  



OS MASTERMAP SITES LAYER – GETTING STARTED GUIDE 
October 2022 

 

OFFICIAL 
© Ordnance Survey Ltd 2023 Page 32 of 54 
 

 

Figure 33: Cadcorp SIS Desktop Overlay Types dialog with the Files > File option selected 
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4. In the File Browser dialog: 

a. Navigate to and select the GML data (.gz file) you want to load. 

b. Click Finish. 

 

Figure 34: Cadcorp SIS Desktop File Browser dialog showing OSMM Topography Layer GML files 

Data processing will begin automatically. You can monitor the progress by watching the spinning blue circle 
in the bottom left of the UI. 
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When processing is complete, the data will display in the Maps panel and Map area. 

Cadcorp produces their own OS MasterMap Topography styling, which automatically styles your OMMM 
Topography data. If you cannot see your data, zoom to > 1:4,000 scale and it should become visible. 

 

Figure 35: Cadcorp SIS Desktop showing loaded OSMM Topography Layer GML data 
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6. MapInfo Professional 
These instructions are based on MapInfo Professional 2019 and assume you have set the default coordinate 
reference system to British National Grid (EPSG 27700). 

Note: While MapInfo Professional can open GML files without prior translation, for performance and compatibility 
reasons, we recommended you use the Universal Translator built into MapInfo Professional versions 12.5 onwards to 
convert the GML supply to MapInfo TAB files prior to loading the data. 

The sections below provide instructions for both working with GML data and converting to MapInfo TAB. 

6.1 Loading and displaying the GML supply 

To load and display the GML supply directly in MapInfo Professional: 

1. Open an existing workspace or create a new one. 

2. From the Home tab, click Open > Universal Data.  

 

Figure 36: MapInfo Professional UI showing Home > Open > Universal Data action 
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3. In the Specify Data Source dialog: 

a. Format: Select GML (Geography Markup Language). 

b. Dataset: Click …, and navigate to and select the GML file (.gz) in the file browser.  

c. Click OK. 

 

Figure 37: MapInfo Professional Specify Data Source dialog 

4. In the Select Layers dialog, select the layers you want to load and click OK. 

 

Figure 38: MapInfo Professional Set Layers dialog 

Your GML data will now display in the Maps panel and map area.  

Note: The data is un-styled. See Related documentation for guidance on styling OSMM Topography Layer data.  
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6.2 Converting GML to MapInfo TAB 

To convert the GML supply to MapInfo TAB in MapInfo Professional: 

1. Open an existing workspace or create a new one. 

2. In the Home tab, click Open > Universal Data. 

 

Figure 39: MapInfo Professional UI showing Home > Open > Universal Data action 

3. In FME Quick Translator, click Translate. 

 

Figure 40: MapInfo Professional UI showing FME Quick Translator actions 
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4. In the Set Translation Parameter dialog: 

a. Reader Format: Select GML (Geography Markup Language). 

b. Reader Dataset: Click …, and navigate to and select the GML file in the file browser. 

c. Format: Select MapInfo TAB (MAPINFO). 

d. Dataset: Click …, and navigate to and select the folder you want the translated data saved to. 

e. Click OK. 

 

Figure 41: MapInfo Professional showing FME Set Translation Parameters dialog 
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You can watch the translation progress log in the FME Quick Translator. It will take some time; a single 5km tile 
of OSMM Topography Layer in GML format takes approximately 30 seconds. When the process is complete, a 
message similar to the example below will display.  

 

Figure 42: MapInfo Professional UI showing FME Quick Translator log 

5. You can now close the FME Quick Translator. 

You can now load the translated data into MapInfo Professional as TAB format using the instructions 
provided in the following section. 

Note: If translating multiple tiles of OSMM Topography Layer using the above method, the files will be automatically 
appended into a single table, avoiding the need to merge tables. However, duplicate features are not removed 
automatically. See Deleting duplicate entries from tables for guidance on how to handle this. 
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6.3 Loading the converted MapInfo TAB files 

To load the converted MapInfo TAB files in MapInfo Professional: 

1. Open an existing workspace or create a new one. 

2. From the Home tab click Open > Table. 

 

Figure 43: MapInfo Professional UI showing Home > Open > Table action 
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3. In the file browser: 

a. Files of type: Select MapInfo (*.tab). 

b. Navigate to the folder in which you stored the converted MapInfo TAB files and select the layers 
you want to open. 

c. Click Open. 

 

Figure 44: MapInfo Professional Open dialog 

Your MapInfo TAB data (.tab) will now display in the Maps panel and map window.  
 
Note: The data is un-styled. See Related documentation below for guidance on styling OSMM Topography Layer 
data.  

6.4 Merging multiple Tab files 

In MapInfo Professional it is possible to merge the elements of two TAB files into one new table using the 
append function.  

Note: Appending only works for data tables of the same type AND for two TAB files at a time. Because OS 
MasterMap Topography Layer data comprises six individual tables, we recommended that you merge two or more 
tiles during the conversion from GML to TAB process. 
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To merge two TAB tables: 

1. Follow the steps in Converting GML to MapInfo TAB above for both files. 

2. Select one of your tables in the Explorer panel. 

3. In the Home tab click Append Rows. 

 

Figure 45: MapInfo Professional UI showing Home > Append Rows action 

4. In the Append Rows to Table dialog: 

a. Append Table: Select the table that will be appended. 

b. to Table: Select the table to append to 

c. Click OK. 

 

Figure 46: MapInfo Professional Append Rows to Table dialog 

The data from one table will now have been appended into the other. You will need to save the table 
to retain the appended data. See below for instructions on how to do this. 
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To verify which table contains the appended data: 

1. Right-click a table in the explorer and click Browse Table in the context menu. 

 

Figure 47: MapInfo Professional UI showing Browse Table action 

The total number of rows in the table displays in the bottom bar; this value of will be considerably larger for the 
table that included the appended rows. 

 

Figure 48: MapInfo Professional UI showing number of table rows 
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To save the table: 

1. Select the table containing the appended rows in the explorer.  

2. From the Table tab click Save > Save Table.  
 
As an alternative, you can use the Save Copy As action to additionally retain the original, unmerged table. 

 

Figure 49: MapInfo Professional UI showing Table > Save > Save Table action 

3. In the Save Table confirmation dialog click Save to confirm your action.  

 

Figure 50: MapInfo Professional Save Table dialog 

Your table will now contain the data for both original TAB files; you can verify this by opening the table to 
check the contents. 

Note: While the files are now merged, duplicate features (resulting from “hairy tiles”) are not removed automatically 
See Deleting duplicate entries from tables for guidance on how to handle this. 
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6.5 Deleting duplicate entries from tables  

There are several ways to delete duplicate entries from tables MapInfo Professional. Please refer to the 
MapInfo Professional documentation for guidance: 

• How to find All Records With Duplicate Values in a Column in MapInfo Pro (precisely.com). This 
article describes how to use SQL queries.  

• User Guide: Search for the Delete Duplicates Tool. 

https://customer.precisely.com/s/article/How-to-find-All-Records-With-Duplicate-Values-in-a-Column-in-MapInfo-Pro?language=en_US
https://docs.precisely.com/docs/sftw/mapinfo-pro/v2021/en-us/pdf/mapinfo-pro-v2021-user-guide.pdf
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7. FME Desktop 
These instructions are based on FME Desktop 2022.1.1. 

7.1 Loading and displaying the GML supply 

To load and display the GML supply in FME Desktop 2022.1.1. 

1. Open an existing workspace or create a new one. 

2. From the Reader tab click Add Reader… 

 

Figure 51: FME Desktop UI showing Readers > Add Reader action 
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3. In the Add Reader dialog: 

a. Format: Select OGC GML (Geography Markup Language). 

b. Dataset: Click …, and navigate to and select the GML file (.gz) in the file browser. 

c. Coord. System: Select ESPG: 27700 (British National Grid). 

d. Click OK. 

 

Figure 52: FME Desktop Add Reader dialog 

4. In the Select Feature Types dialog select the required layers and click OK. 

This dialog may take a while to load. You can watch the progress in the green bar at the bottom left of the FME 
window. 

 

Figure 53: FME Desktop Select Feature Types dialog 

When processing is complete, your features will appear as readers in the FME workspace. 
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5. Right-click one of the feature readers and click Connect Inspector in the context menu. 
 
The Inspector will automatically connect to the reader. 

 

Figure 54: FME Desktop UI showing a selected feature type reader and the Connect Inspector action in the context menu 

The Inspector will automatically connect to the reader. 

6. Click the Inspector and then click the Run to this icon (green triangle above the inspector).  

7. In the Translation Parameter Values dialog click Run. 

 

Figure 55: FME Desktop UI showing selected feature type inspector and Translation Parameter Values dialog 

You can watch the loading progress in the Translation Log below the main workspace.  
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When the run command has completed, the GML table and features will display in the Visual Preview area 
below the main workspace. 

 

Figure 56: FME Desktop UI showing GML table and visual graphic in the Visual Preview area 

8. Repeat steps 5 to 7 above for each layer (feature type) you want to view. 

7.2 Converting GML to shapefile 

You can use FME to convert GML data to other geospatial and non-spatial formats. The instructions below 
demonstrate how to convert GML data to shapefile, but you can adapt them for different formats. 

To convert GML to shapefile in FME Desktop: 

1. Repeat Steps 1 to 4 of the previous section (Loading and displaying the GML supply). 

2. From the Writers tab click Add Writer… 

 

Figure 57: FME Desktop UI showing Writers > Add Writer action 
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3. In the Add Writer dialog: 

a. Format: Select ESRI Shapefile. 

b. Dataset: Click …, and navigate to and select the folder in which to save your translated data. 

c. Coord. System: Select ESPG: 27700 (British National Grid). 

d. Click OK. 

 

Figure 58: FME Desktop Add Writer dialog 

4. In the Select Feature Type dialog select the layers you want to convert and click OK. 

 

Figure 59: FME Desktop Select Feature Type dialog 

This dialog may take a while to load. You can watch the progress in the green bar at the bottom left of the FME 
UI. 

5. Connect each reader to its matching writer by dragging the grey triangle on the reader to the red 
triangle on the writer. 
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Figure 60: FME Desktop UI showing OSMM Topography Layer feature types connected to writers 

6. In the main toolbar click (Run icon) to start the translation. 

 

Figure 61: FME Desktop UI showing connected feature types and writers ready to be run 
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7. In the Translation Parameter Values dialog, check that the source and destination file locations are 
correct and click Run. 

 

Figure 62: FME Desktop Translation Parameter Values dialog 

You can watch the conversion progress in the Translation Log below the main work area. When the 
conversion is complete (indicated by a message similar to the one below), both the GML files and Shapefiles 
will be available in your chosen folders and in the navigator. 

 

Figure 63: FME Desktop UI showing Translation Log 
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8. Astun Technology GML/KML Loader®  
You can use the Astun Technology Loader to convert GML 2.1.2 data to other geospatial and non-
geospatial formats.  

This is a free, open-source loader for geographic data in GML and KML formats. It is written in Python and 
uses OGR 1.9. source data to output to any format supported by OGR, for example, shapefile and MapInfo 
TAB.  

The loader was last updated in September 2022. Installation files and guides for the loader, including 
configuration examples, are available from the AstunTechnology/Loader 
(https://github.com/AstunTechnology/Loader) GitHub repository.   

https://github.com/AstunTechnology/Loader
https://github.com/AstunTechnology/Loader
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9. Related documentation 
You can find additional information and documentation on the OS MasterMap Topograph Layer Product 
page (https://www.ordnancesurvey.co.uk/business-government/products/mastermap-topography). 

We recommend you read the following guides: 

• OS MasterMap Topygraphy Layer – Overview 

• OS MasterMap Topygraphy Layer – Technical Specification 

• Getting Started with GeoPackage 

• Getting Started with Vector Tiles 

• OS MasterMap Topygraphy Layer – Styling Getting Started Guide 

• OS MasterMap Topygraphy Layer – Standard Styling Specification 

https://ordnancesurvey.sharepoint.com/teams/TechnicalDocumentation/Shared%20Documents/Topography%20Layer/OS%20MasterMap%20Topograph%20Layer%20Product%20page
https://ordnancesurvey.sharepoint.com/teams/TechnicalDocumentation/Shared%20Documents/Topography%20Layer/OS%20MasterMap%20Topograph%20Layer%20Product%20page
https://www.ordnancesurvey.co.uk/business-government/products/mastermap-topography
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