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Disclaimer: Unless otherwise stated, the content in this work is provided for general information only and 
it is not intended to amount to advice on which the reader should rely. Ordnance Survey therefore 
disclaims all liability and responsibility arising from any reliance placed on such content. Professional or 
specialist advice should be obtained before taking, or refraining from, any action on the basis of the content 
herein. 
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1. Introduction 
This guide explains what vector tiles are, lists the key features and benefits of the format, and details the 
applications that support vector tiles. Section 2 provides step-by-step instructions on how to install vector 
tiles data in QGIS and Cadcorp. Section 3 details how to install vector tiles in Mapbox. Section 4 provides 
information on hosting and serving your own vector tiles, while Section 5 gives step-by-step instructions on 
using OS styles on vector tiles you have created. 

In response to customer feedback on preferred data formats, a growing number of OS products have been 
made available in vector tile format, including OS Open Zoomstack, OS VectorMap Local, Code-Point with 
Polygons, Boundary-Line, OS Terrain 50, OS Open Roads and OS MasterMap Greenspace Layer, to name a 
few. We also have the OS Vector Tile API on the OS Data Hub (https://osdatahub.os.uk/) if you want to 
connect directly to OS-hosted vector tiles. 

1.1 What are vector tiles? 

Vector tiles are clipped tiles, or grid squares, composed of layers of vector features which are optimised 
for caching, scaling, and producing map imagery quickly. They serve in a similar way to raster tiles but have 
the added functionality of being customisable by users. 

A vector tile represents a specific area of the Earth’s surface and contains geographic information about the 
coverage area. Each tile can contain many layers of features, such as buildings, roads, rivers, greenspaces, 
etc. Vector tiles are packets of geographic data which have been packaged into tiles for transfer over the 
web. The information they contain can be used to deliver styled vector data and web maps to the end-user. 

Note: OS supplies data in the Mapbox Vector Tile Specification, packed in a single MBTiles file (which is based on 
the SQLite database). This is a Mapbox-specific vector tile format. Other specifications are available; however, this 
document will reference MBTiles only. 

1.2 Key features and benefits of vector tiles 

Vector tiles offer users the following key features and benefits: 

• User customisation and styling functionality – customise your map with full and dynamic design control. 

• Small file size – lightweight tiles that are efficient and quick to render in your client application. 

• Pixel perfect maps – high-resolution, beautiful mapping for all devices (web and mobile devices). 

• Snapping ability – due to the data being vector, data can be snapped to and traced. 

• Smooth zooming and scaling effect – a seamless user experience when zooming in and out of maps. 

• Advanced features – vector tiles contain geographic data (not just images) which can be interrogated 
and analysed. 

• Offline maps – store the tiles locally to take your maps offline (for example, on mobile devices). 

• Data will be supplied in Web Mercator projection (EPSG:3857). 

https://osdatahub.os.uk/
https://osdatahub.os.uk/
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2. Installing vector tiles in GIS software 
The following sub-sections provide step-by-step instructions on how to install vector tiles data in QGIS and 
Cadcorp. 

2.1 Installing vector tiles data in QGIS 

Requirements: 

• QGIS (version 3.14 or later) 
• Vector tiles 

Note: These instructions were created using QGIS version 3.14 – a Long Term Release version. 

1. Download your vector tiles (MBTiles) and save them in a preferred location. 

2. Load QGIS Desktop and open a new or an existing project. 

3. From the top ribbon of the workspace, click Layer > Add Layer > Add Vector Tiles Layer... 
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4. In the Add Layer(s) from a Vector Tile Source dialog box, select the MBTiles tab and then click Browse. 

 

5. In the file explorer, navigate to your saved vector tiles and click Open. 

6. In the Options section, select the Base map defaults option. 

a. Note that the Base map defaults option sets the maximum number of loaded tiles as 32. You can 
decrease or increase this limit as preferred if you select the Manual option instead. 

b. Note that the greater the number of tiles loaded, the greater the resulting impact on performance 
and the longer the loading times for the data. 

7. Click Add. 

The data will now appear in your Layers Panel and will render in your map window. 

8. Click Close to return to the map window. 
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2.1.1 Adding stylesheets to OS vector tiles products in QGIS 

Vector tiles can be styled in any way desired. However, if you want to style them with OS styling, 
stylesheets for vector tiles can be found on GitHub (https://github.com/OrdnanceSurvey) on a product-by-
product basis. 

To add stylesheets to OS vector tiles products in QGIS, please use the following instructions: 

1. Download the appropriate repositories from GitHub (https://github.com/OrdnanceSurvey). The 
example below shows a screenshot of the GitHub repository containing OS Open Zoomstack 
stylesheets: 

 

2. Store the downloaded repository in a sensible folder location. 

3. Navigate to your QGIS project with the vector tile data loaded. Double-click on your vector tile layer 
and navigate to the Symbology tab on the left-hand ribbon of the Layer Properties dialog box. 

https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
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4. In the bottom left of the Layer Properties dialog box, select Style > Load Style... 

 

5. In the Database Styles Manager dialog box, select From File as your Load style option. 

6. For the File option, you will need to navigate to the folder where you stored the downloaded 
stylesheet repository. The vector tiles stylesheet will be found in Vector Tiles > Mapbox GL Styles, and 
the file type will be .json. 

 

7. Click Load Style to load the style. 

A styled vector tile dataset will now be visible in the project. 
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2.2 Installing vector tiles data in Cadcorp 

Requirements: 

• Cadcorp SIS Desktop (version 9) 
• Vector tiles 

Note: As OS vector tiles are only available in Web Mercator projection, you will need to undertake a few extra steps 
to be able to use them within Cadcorp. Additionally, the tiles will not be reprojected into British National Grid (BNG), 
so the tiles may create some gaps within the data. 

The following instructions outline how to change the projection of your basemap from British National 
Grid (EPSG:27700) to WGS 84 (EPSG:4326) in Cadcorp: 

1. Open Cadcorp SIS Desktop (version 9) and navigate to Add Overlay in the upper ribbon. 

2. In the Overlay Types dialog box, select Miscellaneous > Backdrop, then click Next. 

 

3. Expand WGS 84 and select WGS 84 Lat/Long. 

4. Click Finish. 

A basemap projected in WGS 84 will appear in the map screen. It is now possible to follow either 
method 1 or method 2 on the following pages to add vector tiles to a Cadcorp project. 
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The following sub-sections outline two methods for installing vector tiles in Cadcorp. 

2.2.1 Method 1: Drag-and-drop 

1. Download the vector tiles (MBTiles) and save them in a preferred location. 

2. Start Cadcorp SIS Desktop and open a new or an existing map window. 

3. Navigate to your saved vector tiles in file explorer and drag-and-drop the file into the map window. 

The data will appear in your Maps Control Bar and render in your map window. 

2.2.2 Method 2: Add Overlay 

1. Download the vector tiles (MBTiles) and save them in a preferred location. 

2. Start Cadcorp SIS Desktop and open a new or an existing map window. 

3. In the upper ribbon, navigate to the Home tab and click Add Overlay. 

 

4. In the Overlay Types dialog box, select Files > File as the Overlay type, then click Next. 
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5. In the File Browser dialog box, navigate to and select your saved vector tiles, then click Finish. 

 

The data will now appear in your Maps Control Bar and render in your map window. 
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2.2.3 Adding stylesheets to OS vector tiles products in Cadcorp SIS Desktop 

Vector tiles can be styled in any way desired. However, if you want to style them with OS styling, 
stylesheets for vector tiles can be found on GitHub (https://github.com/OrdnanceSurvey) on a product-by-
product basis. 

Note: OS Open Zoomstack stylesheets can be automatically applied when adding this product into CadCorp SIS 
Desktop. While vector tile stylesheets do exist for OS VectorMap Local, they cannot currently be applied in Cadcorp 
SIS Desktop. 

To add stylesheets to OS vector tiles products in Cadcorp SIS Desktop, please use the following 
instructions: 

1. Download the appropriate repositories from GitHub (https://github.com/OrdnanceSurvey). The 
example screenshot below shows a screenshot of the GitHub repository containing OS Open 
Zoomstack stylesheets. 

 

2. Add the stylesheets file to the folder where the MBTiles are also stored and rename the stylesheets file 
so that it has the same name as the MBTiles file. 

3. Add the following file extension to the end of the newly named stylesheets file: .style.json 

 

4. Drag and drop the style.json file into your Cadcorp SIS Desktop project. 

The styling will now be applied to your layer. 

https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
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3. Installing vector tiles in Mapbox 
Requirements: 

• A Mapbox account 
• Vector tiles 

1. Download your vector tiles (MBTiles) and save them in a preferred location. 

2. Navigate to Mapbox Studio (https://www.mapbox.com/mapbox-studio/) and login to your account. 

3. The vector tiles can be uploaded in the Tilesets section of Studio (https://studio.mapbox.com/tilesets/). 
In the Tilesets page, click New tileset. 

 

4. In the New tileset pop-up, click Select a file and navigate to the saved location of your MBTiles. 

 

The upload will begin, and a notification will appear once it is complete. 

Note: There is an upload limit within Mapbox Studio of 300mb per upload and 20 uploads per month. 

https://www.mapbox.com/mapbox-studio/
https://www.mapbox.com/mapbox-studio/
https://studio.mapbox.com/tilesets/
https://studio.mapbox.com/tilesets/
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3.1 Using OS styles to get started in Mapbox Studio 

OS has supplied Mapbox GL Styles created by our cartographic designers for use in Mapbox Studio on 
GitHub (https://github.com/OrdnanceSurvey). These stylesheets allow you to add colours to features 
contained in the vector tiles to produce a far more vivid and visually appealing map. 

The following step-by-step instructions will guide you through setting up Mapbox GL Styles in Mapbox 
Studio: 

1. Download the appropriate repositories from GitHub (https://github.com/OrdnanceSurvey). The 
example screenshot below shows a screenshot of the GitHub repository containing OS Open 
Zoomstack stylesheets. This downloaded repository should be stored in an appropriate location. 

 

2. Navigate to Mapbox Studio to complete the next set of instructions. 

3. Copy the Map ID for your new tileset by doing the following: 

a. In Mapbox Studio, click on the Tilesets tab in the top right corner. 

 

b. Scroll down until you see your new tileset and click the Menu button. 

 

https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
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c. Click on the clipboard icon to copy the Map ID. 

 

4. Open the folder of stylesheets that you downloaded in step 1 and navigate to Vector Tiles > Mapbox GL 
Styles, where you will find four styles (Road, Outdoor, Light, and Night). 

5. Choose the style that you want to use, then open the .json file (for example, Outdoor.json) in a text 
editor. 

6. Find the following block of code near the top of the file (line 46) and paste your Map ID where it says 
ADD-SOURCEURL-HERE: 

 

7. Save the .json file. 

8. Go back to Mapbox Studio and click the Styles tab. 

 

9. Click the Upload button. 

10. Navigate to your newly saved style.json file and click Open. 

The style will then load up in the Mapbox Studio style editor. 

From this point on, you can customise the content and style of your map (for example, you can turn 
layers on or off, delete layers from your map, add new layers, and change any of the style elements).  

11. Once you are happy with your map, click Publish in the top right corner and your map is ready to use. 
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4. Hosting and serving your own vector tiles 
There are a couple of benefits associated with hosting and serving your own vector tiles: 

• There are no thresholds when uploading your own data to create the tiles. 

• You do not need external connectivity to use the tiles as the hosting can be done locally (i.e. you can 
work offline with the vector tiles). 

There are numerous options if you want to host and serve your own vector tiles. The following GitHub 
repositories have comprehensive lists of the available options for vector tiles and those available specifically 
for MBTiles: 

• GitHub repository listing choices available for hosting and serving your own vector tiles 
(https://github.com/mapbox/awesome-vector-tiles/blob/master/README.md). 

• GitHub repository listing choices available for hosting and serving your own MBTiles 
(https://github.com/mapbox/mbtiles-spec/wiki/Implementations). 

If you want to export an MBTiles file to a directory of files, you can use open-source tools such as 
Tippecanoe (https://github.com/mapbox/tippecanoe/) or MBUtil (https://github.com/mapbox/mbutil). 

https://github.com/mapbox/awesome-vector-tiles/blob/master/README.md
https://github.com/mapbox/awesome-vector-tiles/blob/master/README.md
https://github.com/mapbox/mbtiles-spec/wiki/Implementations
https://github.com/mapbox/mbtiles-spec/wiki/Implementations
https://github.com/mapbox/tippecanoe/
https://github.com/mapbox/tippecanoe/
https://github.com/mapbox/mbutil
https://github.com/mapbox/mbutil
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5. Using OS styles on vector tiles you have created 
It is possible to use OS styles on vector tiles you have created. The following step-by-step instructions 
outline how to do this: 

1. Download and unzip the appropriate OS product folder of stylesheets from GitHub 
(https://github.com/OrdnanceSurvey), for example, OS's OS-Open-Zoomstack-Stylesheets repository 
on GitHub (https://github.com/OrdnanceSurvey/OS-Open-Zoomstack-Stylesheets). 

2. Once you have downloaded and unzipped the folder of stylesheets, navigate to Vector Tiles > Mapbox GL 
Styles. 

3. If appropriate, choose the style you want to use and open the .json file (for example, OS Outdoor.json) 
in a text editor. 

4. Find the following piece of code near the top of the file and enter your data source URL where it says 
ADD–SOURCE–URL–HERE: 

 

Note: You can find more information on the different source types on Mapbox's documentation site 
(https://docs.mapbox.com/mapbox-gl-js/style-spec/sources/). 

5. Save the .json file. 

The style is now ready to use. You can customise the style if you want to (for example, you could adapt 
the style of a map to match your own brand colours). Maputnik (https://maputnik.github.io/) is a good 
open-source map editor tool for creating and customising vector tile styles. 

https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey/OS-Open-Zoomstack-Stylesheets
https://github.com/OrdnanceSurvey/OS-Open-Zoomstack-Stylesheets
https://github.com/OrdnanceSurvey/OS-Open-Zoomstack-Stylesheets
https://docs.mapbox.com/mapbox-gl-js/style-spec/sources/
https://docs.mapbox.com/mapbox-gl-js/style-spec/sources/
https://maputnik.github.io/
https://maputnik.github.io/
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Annex A: Additional resources 
Stylesheets for OS products are available on our GitHub pages (https://github.com/OrdnanceSurvey). 

The following OS blog posts contain useful information about vector tiles: 
• OS blog post: The benefits of vector tiles (https://www.ordnancesurvey.co.uk/newsroom/blog/the-

benefits-of-vector-tiles) 

• OS blog post: Creating your own vector tiles 
(https://www.ordnancesurvey.co.uk/newsroom/blog/creating-your-own-vector-tiles) 

• OS blog post: An interactive house prices map with OS data 
(https://www.ordnancesurvey.co.uk/newsroom/blog/house-prices-map-os-data) 

https://github.com/OrdnanceSurvey
https://github.com/OrdnanceSurvey
https://www.ordnancesurvey.co.uk/newsroom/blog/the-benefits-of-vector-tiles
https://www.ordnancesurvey.co.uk/newsroom/blog/the-benefits-of-vector-tiles
https://www.ordnancesurvey.co.uk/newsroom/blog/the-benefits-of-vector-tiles
https://www.ordnancesurvey.co.uk/newsroom/blog/creating-your-own-vector-tiles
https://www.ordnancesurvey.co.uk/newsroom/blog/creating-your-own-vector-tiles
https://www.ordnancesurvey.co.uk/newsroom/blog/house-prices-map-os-data
https://www.ordnancesurvey.co.uk/newsroom/blog/house-prices-map-os-data
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